Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#76651 - [gtk3] Breaks cursor in Firefox

Attached to Project: Arch Linux
Opened by Aidan Dang (AidanGG) - Thursday, 24 November 2022, 03:47 GMT
Last edited by Buggy McBugFace (bugbot) - Saturday, 25 November 2023, 20:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
The upgrade to gtk 1:3.24.35-1 results in weird behaviour of the cursor in Firefox, including not changing appearance when hovering over links, and sometimes even fully disappearing.
Expected behaviour with the previous 1:3.24.34+r156+g812b3930d0-1 release.

Additional info:
gtk 1:3.24.35-1
sway 1:1.7-10
firefox 107.0-1 (but might possibly occur with other GTK-based apps?) running in Wayland (MOZ_ENABLE_WAYLAND=1).

Steps to reproduce:
Configure the above and observe cursor behaviour.
This task depends upon

Closed by  Buggy McBugFace (bugbot)
Saturday, 25 November 2023, 20:17 GMT
Reason for closing:  Moved
Additional comments about closing:  https://gitlab.archlinux.org/archlinux/p ackaging/packages/gtk3/issues/2
Comment by Toolybird (Toolybird) - Thursday, 24 November 2022, 05:42 GMT
Cannot repro in a fresh sway env set up in a new VM with the steps provided. What scale are you using? Is  FS#76018  related? What about this [1]? Have you reported it upstream?

[1] https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/5192
Comment by Aidan Dang (AidanGG) - Thursday, 24 November 2022, 08:31 GMT
Sorry, I forgot to mention in the original report that I was using nvidia-open. Trying on my Intel device, I was also unable to reproduce the issue, so it appears to be some weird interaction with Nvidia (to be expected).

I'm using just normal 1x scale, so I don't think  FS#76018  is related. I can try playing around with bisecting around GTK MR!5192 to see if that is the issue. (I'll try to open an upstream report soon)
Comment by Adam Kürthy (adee) - Thursday, 24 November 2022, 11:32 GMT
With amdgpu+250% scaling in Gnome-shell I have no visible cursor over any GTK3 surfaces anymore.
Comment by Marcelo Marzola Bossoni (mmbossoni) - Thursday, 24 November 2022, 16:14 GMT
Can confirm this bug on my machine as well.
Cursors are all messed up. Reverting to previous 3.24.34+r156+g812b3930d0 get it working again
Nvidia gpu with closed dkms drivers on wayland (firefox running in wayland mode)
Comment by Adam (twokilohertz) - Friday, 25 November 2022, 03:50 GMT
Had it occur to me just now too. Updated, rebooted & now have this issue. I've noticed the issue in Firefox & Evince. I'm using GNOME & Wayland on the latest kernel on my ThinkPad T440p with Intel graphics. I have MOZ_ENABLE_WAYLAND set to 1, does also occur in Evince too though (PDF reader).
Comment by freswa (frederik) - Friday, 25 November 2022, 11:36 GMT
Can confirm gtk3 3.24.35 breaks cursor with gtk applications. For me this happens only with cursor themes installed to ~/.icons/.
E.g. evince prints error messages like these to stdout (gone if I install xcursor-breeze from AUR):
Gdk-Message: 12:32:54.628: Unable to load nw-resize from the cursor theme
Gdk-Message: 12:32:54.628: Unable to load n-resize from the cursor theme
Gdk-Message: 12:32:54.628: Unable to load ne-resize from the cursor theme

This behavior is gone with 3.24.34+r156+g812b3930d0
Comment by Aidan Dang (AidanGG) - Friday, 25 November 2022, 11:44 GMT
I also had my cursor theme installed to ~/.icons. A quick test with breeze_cursors from the breeze package (/usr/share/icons/breeze_cursors) seems to work fine with gtk3 3.24.35.
Comment by freswa (frederik) - Friday, 25 November 2022, 11:47 GMT
Checked if the theme is the issue, but copying /usr/share/icons/breeze_cursors to ~/.icons and removing the cursor pkg breaks it again.
Comment by Jan Alexander Steffens (heftig) - Friday, 25 November 2022, 14:00 GMT
Upstream issue: https://gitlab.gnome.org/GNOME/gtk/-/issues/5365

I'm not affected (GNOME).
Comment by Jan Alexander Steffens (heftig) - Friday, 25 November 2022, 14:16 GMT Comment by freswa (frederik) - Friday, 25 November 2022, 14:19 GMT
No, still getting errors.

Gdk-Message: 15:18:50.892: Unable to load nw-resize from the cursor theme
Gdk-Message: 15:18:50.892: Unable to load n-resize from the cursor theme
Gdk-Message: 15:18:50.892: Unable to load ne-resize from the cursor theme
Comment by Aidan Dang (AidanGG) - Friday, 25 November 2022, 14:22 GMT
Strange, heftig's package does fix it for me, at least on Firefox.
Comment by Marcelo Marzola Bossoni (mmbossoni) - Friday, 25 November 2022, 15:06 GMT
Using package provided at https://pkgbuild.com/~heftig/gtk3-issue5365/ does fix the issue to me, at least on firefox
Comment by Jan Alexander Steffens (heftig) - Friday, 25 November 2022, 18:57 GMT
gtk3 1:3.24.35-2 should improve this.
Comment by freswa (frederik) - Friday, 25 November 2022, 21:28 GMT
Heftig and I found out that the behavior changed wrt the default folder. GTK3 used to check for the default folder in ~/.icons and in ~/.local/share/icons. This is no more the case, the default folder is only recognized in /usr/share.
Comment by Curtis (foxcm2000) - Thursday, 01 December 2022, 21:36 GMT
I'm having the same bug using gtk3 1:3.24.35-2 and firefox 107.0.1-1 on a laptop with Intel Gen12 (Tiger Lake) graphics. This is under Wayland (firefox running native, not in XWayland) with KDE Plasma as the desktop environment.

The easiest way for me to trigger the bug is to go to youtube and run a fullscreen video. The cursor will disappear or the wrong cursor will be displayed. Exiting the video does not help because the cursor remains broken even on other tabs that have nothing to do with the original video.
Comment by Bruno (pazitos10) - Thursday, 07 September 2023, 02:34 GMT
I think I'm experimenting a similar issue. In my case, I can trigger the bug by opening firefox maximizing the size of the window, hovering over tabs and icons in the homepage, minimizing the window and reopening it. In this state, the hover effect stops working and the app becomes very sluggish. Sometimes, usually on full screen youtube videos, the cursor dissapears and the only way I can recover it is by moving my mouse over my other display (multi-monitor setup) and then back over firefox. No relevant error messages show in journalctl regarding gtk3, firefox or cursor after experiencing the error.

gtk3 1:3.24.38-1
firefox 117.0-1
wayland 1.22.0-1
Comment by Lucas Francisco Gonçalves (galegovski) - Friday, 22 September 2023, 20:23 GMT
I am presenting an error identical to the one reported by Bruno (pazitos10).
But I had already gone through similar problem in the past, when I upgraded to gnome-shell 44, the previous error was resolved by deleting the pamac extension.
However, today I do not have the extension installed and the error returned.

Note: If you minimize the firefox window you will be able to click on the top right corner of firefox. Which apparently shows that it's a fixed area on the screen. The same, used in the past by the pamac extension, and now must be conflicting with something else from gnome-shell, or some extension.

Note2: This has been translated by Google Translate. Sorry.

firefox - 117.0.1-1
gtk3 - 1:3.24.38-1
gtk4 - 1:4.12.2-1
gnome-shell - 1:44.5-1
wayland - 1.22.0-1
Comment by Lucas Francisco Gonçalves (galegovski) - Friday, 29 September 2023, 20:58 GMT
After the latest Firefox and GTK4 updates, the problem was fixed here.

firefox 118.0.1-1
gtk4 1:4.12.3-1

How is it for y’all?
Comment by Bruno (pazitos10) - Monday, 02 October 2023, 21:22 GMT
After updating my system, I'm still unfortunately getting the errors I experienced before. In my case, I've got: gtk4 1:4.12.2-1 and firefox 118.0-1. I will try to trigger it again and upload my logs.

Edit: Today I've been using Gnome in Wayland have been present since the start of the day on firefox but I don't see any messages related to this issue in my journalctl output. See attached files (one contains the whole log since today and the other one, just the kernel messages). If there's any other file I could search for, let me know.

Loading...