Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#76531 - [virtualbox] 7.0.2-2 Windows 11 guest is unresponsive

Attached to Project: Arch Linux
Opened by Ralf Mardorf (Ralf) - Friday, 11 November 2022, 18:50 GMT
Last edited by Toolybird (Toolybird) - Monday, 14 November 2022, 05:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Waiting on Response
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Hi, I was able to use a Windows 11 guest with community/virtualbox 7.0.2-1, but with community/virtualbox 7.0.2-2 the guest becomes unresponsive short after a successful startup and login.
Apart from a fast and noisy fan the host doesn't suffer from this issue.
I run community/virtualbox 7.0.2-1 with successfully with a rt-patched linux 4.19.246-rt110 I build myself.
It fails with community/virtualbox 7.0.2-2 with a rt-patched linux 4.19.255-rt113 using the same config as 4.19.246-rt110 and with core/linux 6.0.8.arch1-1 threadirqs.

[rocketmouse@archlinux ~]$ grep x......th /boot/syslinux/syslinux.cfg -A3
MENU LABEL Arch Linux ^threadirqs
LINUX ../vmlinuz-linux
APPEND root=LABEL=s3.archlinux ro threadirqs
INITRD ../intel-ucode.img,../initramfs-linux.img

Upstream:
https://forums.virtualbox.org/viewtopic.php?f=7&t=107757
https://forums.virtualbox.org/viewtopic.php?f=7&t=107757#p527439
[...]
Arch forums:
https://bbs.archlinux.org/viewtopic.php?pid=2067415#p2067415
Arch-general :
arch-general@lists.archlinux.org/thread/GSDRGWQEULBUM254XGBZLX7NCFWF5FCE/"> https://lists.archlinux.org/archives/list/arch-general@lists.archlinux.org/thread/GSDRGWQEULBUM254XGBZLX7NCFWF5FCE/
Regards, Ralf
   VBox.log (193.1 KiB)
This task depends upon

Comment by tekstryder (Tekstryder) - Friday, 11 November 2022, 19:46 GMT
Ran into this myself today. I was trying to stay on VB 6.1.40 for as long as I could but the OpenSSL 3.0 rebuild forced my hand.

The VM appears to be running per the log and Manager's activity page. Issuing an ACPI shutdown is successful. It appears the display may simply be mangled.

FWIW, I dual boot with Debian Stable for exactly this kind of reason. I booted the VM from Debian and downgraded GA to 6.1.40.

Back in Arch that did not resolve the issue... the Win11 VM is still busted. However this does appear to be specific to Win11 guest as my Win10 guest boots just fine and is running GA 7.0.2.
Comment by tekstryder (Tekstryder) - Friday, 11 November 2022, 19:58 GMT
Attaching my log if it may help
   VBox.log (342.9 KiB)
Comment by Ralf Mardorf (Ralf) - Friday, 11 November 2022, 20:27 GMT
Hi,

after downgrading the Arch guest additions package, installing the downgraded guest additions by the Windows 11 guest and restarting the Windows 11 guest, it is running for several minutes now without freezing.

$ uname -r; cat /proc/cmdline; pacman -Q virtualbox{,-ext-oracle,-guest-iso,-host-dkms}
6.0.8-arch1-1
BOOT_IMAGE=../vmlinuz-linux root=LABEL=s3.archlinux ro threadirqs initrd=../intel-ucode.img,../initramfs-linux.img
virtualbox 7.0.2-2
virtualbox-ext-oracle 7.0.2-1
virtualbox-guest-iso 6.1.40-1
virtualbox-host-dkms 7.0.2-2

Regards,
Ralf
Comment by tekstryder (Tekstryder) - Friday, 11 November 2022, 21:41 GMT
That didn't work for me. Fortunately the VM boots just fine under Debian with VB 6.1.40 so this is simply an annoyance until resolved.

$ uname -r; cat /proc/cmdline; pacman -Q virtualbox{,-ext-oracle,-guest-iso,-host-dkms}
6.0.8-arch1-1
initrd=\intel-ucode.img initrd=\initramfs-linux.img root=UUID=d475ae3e-f8c5-4e02-9c23-541d4667d78e rw pci=noaer ibt=off nvidia_drm.modeset=1 module_blacklist=snd_hda_intel
virtualbox 7.0.2-2
error: package 'virtualbox-ext-oracle' was not found
virtualbox-guest-iso 6.1.40-1
virtualbox-host-dkms 7.0.2-2

This is all I see when booting the Win11 VM:
https://postimg.cc/MM9J8F0n

EDIT1: Not that I really suspected this to be related to kernel version but the Win11 VM also fails booting when my Arch host is using the LTS kernel 5.15.77-1 but successfully boots via Debian with kernel 5.15.77 I compiled.
EDIT2: If I disable the 3D Acceleration option the VM boots successfully. Not really a viable workaround as I need full resolution, but hopefully helps narrow the issue.
EDIT3: Looks like I _can_ get full resolution with 3D Acceleration disabled. I was then able to install GA 7.0.2 and the VM is fully functional, albeit without the aforementioned 3D Acceleration.
Comment by tekstryder (Tekstryder) - Saturday, 12 November 2022, 18:50 GMT
Per this gnome-shell issue:
https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/6054

I built mutter 43.1 with 7e7a639c reverted:
https://gitlab.gnome.org/GNOME/mutter/-/commit/7e7a639cc5132cf3355e861235f325540fe56548

The Virtualbox issue is no longer reproducible. Bonus - some other funky stuff like broken text highlighting in firefox and borked dash-to-panel extension are working properly again too.
Comment by Ralf Mardorf (Ralf) - Saturday, 12 November 2022, 19:30 GMT
Hi, mutter isn't installed on my machine. I run openbox sessions without a desktop environment. Regards, Ralf
Comment by Ralf Mardorf (Ralf) - Sunday, 13 November 2022, 13:32 GMT
[virtualbox 7.0.2] doesn't work with a Windows 11 guest on an Arch Linux host
Upstream ticket: https://www.virtualbox.org/ticket/21268

Hi,

while downgraded guest additions solved a freeze issue with a Windows 11 guest, USB is broken.

There are no issues with a Windows 7 or a Windows 10 guest.

$ uname -r; pacman -Q virtualbox
4.19.255-rt113-0.1000
virtualbox 7.0.2-2

Windows 7

guest never updated to guest additions version 7.0.2r154219
now at version 6.1.40r154048
USB 2.0 enabled does work with my iPads connected by USB

Windows 10

guest updated to guest additions version 7.0.2r154219
now at version 7.0.2r154219
USB 2.0 enabled does work with my iPads connected by USB

Windows 11

guest updated to guest additions version 7.0.2r154219 does cause freezes
downgraded to guest additions version 6.1.40r154048
now at version 6.1.40r154048 no freezes anymore, but
USB 2.0 as well as USB 1.1 enabled do n o t work with my iPads

For more details, see [snip]

https://forums.virtualbox.org/viewtopic.php?f=7&t=107757

https://bbs.archlinux.org/viewtopic.php?id=281196

arch-general@lists.archlinux.org/thread/GSDRGWQEULBUM254XGBZLX7NCFWF5FCE/#GSDRGWQEULBUM254XGBZLX7NCFWF5FCE"> https://lists.archlinux.org/archives/list/arch-general@lists.archlinux.org/thread/GSDRGWQEULBUM254XGBZLX7NCFWF5FCE/#GSDRGWQEULBUM254XGBZLX7NCFWF5FCE

Regards,

Ralf
Comment by Toolybird (Toolybird) - Monday, 14 November 2022, 05:43 GMT
So the only difference between 7.0.2-1 and 7.0.2-2 is OpenSSL 3.0. It's hard to fathom that Windows 11 failing is somehow an Arch packaging bug. It seems likely upstream need to get their stuff working with OpenSSL 3.0. I cannot see an openssl version number mentioned here [1]. I wonder if other distros are building VB against OpenSSL 3.0?

[1] https://www.virtualbox.org/wiki/Linux%20build%20instructions
Comment by Ralf Mardorf (Ralf) - Monday, 14 November 2022, 07:10 GMT
Obviously an upstream bug in 7.0.2 does cause an incompatibility with Windows 11. Since installing Windows 11 as a virtualbox guest is already tricky, I'm not surprised.
I build virtualbox 6.1.40 against core/openssl 3.0.7-2 and there are no issues at all when running the Windows 11 guest in virtualbox 6.1.40.
The script to build it in a clean chroot: https://pastebin.com/sKzMmun4

$ pacman -Qi virtualbox virtualbox-host-dkms virtualbox-guest-iso|grep -eVe -ed\ D
Version : 1:6.1.40-702.2
Build Date : Sun 13 Nov 2022 21:24:27 CET
Version : 1:6.1.40-702.2
Build Date : Sun 13 Nov 2022 21:24:27 CET
Version : 6.1.40-1
Build Date : Sat 15 Oct 2022 12:18:22 CEST
$ /usr/bin/ls -l /usr/share/virtualbox/extensions/*
-rw-r--r-- 1 root root 11233264 Oct 11 18:15 /usr/share/virtualbox/extensions/Oracle_VM_VirtualBox_Extension_Pack-6.1.40.vbox-extpack

Building virtualbox takes around 50 minutes on my machine, if there is a bump of the community/virtualbox 7.0.2 pkgrel, to rebuild it against updated dependencies, I'll try to rebuild virtualbox 6.1.40, too.
For the time being this seems to be the only workaround.

Loading...