Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7648 - fc-cache segfault while caching

Attached to Project: Arch Linux
Opened by Radu Potop (wooptoo) - Sunday, 22 July 2007, 19:25 GMT
Last edited by Roman Kyrylych (Romashka) - Thursday, 06 September 2007, 14:30 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

fc-cache segfaults when trying to cache this directory:

fc-cache -fv

/usr/share/fonts/TTF/free: segfault

"free" contains 437 fonts. If I remove it then fc-cache works fine. It's strange since it worked before and the directory's contents didn't change.
I tried adding the path to "free" in xorg.conf and/or local.conf, or put the fonts in ~/.fonts, but with no luck.

I think the problem is with fontconfig/fc-cache since the fonts worked before.
You can find the fonts here if you want to test this: http://web.omnidrive.com/APIServer/public/6pcMDEClbYween1HmyjXvl1y%2Ffonts > free.zip (~11mb)
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Thursday, 06 September 2007, 14:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  author of report said it is solved
Comment by Radu Potop (wooptoo) - Thursday, 06 September 2007, 12:37 GMT
It looks like fontconfig didn't like two of my fonts. Maybe they are corrupted... or something.
They are: Bit 01 and BitMirror. I attached them if you want to test this out.

Loading...