Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#76367 - [remmina] phodav 3.0 / libsoup crash

Attached to Project: Community Packages
Opened by Hartmut Malzahn (hwm) - Tuesday, 01 November 2022, 08:12 GMT
Last edited by Toolybird (Toolybird) - Thursday, 03 November 2022, 01:31 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No



after upgrading packages today, remmina crashes with this error:

libsoup-ERROR **: 09:09:28.961: libsoup2 symbols detected. Using libsoup2 and libsoup3 in the same process is not supported.

Downgrading these packages fixes the error:

spice-gtk (0.41-4 => 0.41-3)
virt-viewer (11.0-2 => 11.0-1)
phodav (3.0-1 => 2.5-2)
libgovirt (2:0.3.9-1 => 2:0.3.8-1)

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Toolybird (Toolybird)
Thursday, 03 November 2022, 01:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  remmina 1:1.4.27-4
Comment by Toolybird (Toolybird) - Tuesday, 01 November 2022, 08:33 GMT Comment by jano (jancici) - Tuesday, 01 November 2022, 11:01 GMT
well, it is not clear to me, what is workaround or solution? thanks
Comment by Lázár György (gyurci) - Tuesday, 01 November 2022, 11:14 GMT
Can confirm, broken for me also (on two separate and independent machines).
Comment by Ovear (ovear) - Tuesday, 01 November 2022, 12:17 GMT
Guys, workaround here in case someone needs it, require arch build system and manually build.
Check more information here
Comment by Darrell (denns) - Tuesday, 01 November 2022, 18:19 GMT
Applying the upstream patch and changing the dependency from webkit2gtk to webkit2gtk-4.1 worked for me. Cherry picking the upstream patch until the next release seems like a good solution.
Comment by Toolybird (Toolybird) - Wednesday, 02 November 2022, 05:47 GMT
> Cherry picking the upstream patch until the next release seems like a good solution.

Agreed. Here's the patch [1]. Of course in the meanwhile, the workaround is to uninstall spice-gtk (but that's not possible if you use virt-manager, virt-viewer, gnome-boxes, etc)

Comment by Adrian Martis (sitram) - Wednesday, 02 November 2022, 07:32 GMT
I had the same error and I was able to make remmina work again by downgrading only one package

spice-gtk (0.41-4 => 0.41-3)

Command example on my system:
sudo pacman -U