Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7627 - winecfg and wine games/apps takes ages to load if i have ran 'dhcpcd wlan0'

Attached to Project: Arch Linux
Opened by kongokris 2 (nut543) - Tuesday, 17 July 2007, 16:08 GMT
Last edited by Roman Kyrylych (Romashka) - Saturday, 15 December 2007, 13:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dale Blount (dale)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
winecfg and wine games/apps takes ages to load if i have ran 'dhcpcd wlan0'

if i run 'dhcpcd -k wlan0' then winecfg and games/apps starts instantly again. completely reproducible.

I've tried a bunch of different /etc/hosts combinations too, but can't get it to work. (This file is so confusing!!!)

This also happens with GNOME logout... If i select gnome logout after having ran dhcpcd wlan0 i have to wait a looong time before it logs out, whereas if i run dhcpcd -k wlan0(or never run it in the first place) and press logout it's instant.

right now my /etc/hosts:
127.0.0.1 localhost.localdomain localhost

This has been the case for many wine rel. and even with newest wine .41 the problem persists. Someone should really get to the bottom of this slowness problem, there's variations of it all over the net for many years now.

Maybe it's possible to get rid of /etc/hosts? No, just an idea.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Saturday, 15 December 2007, 13:47 GMT
Reason for closing:  Fixed
Comment by kongokris 2 (nut543) - Tuesday, 17 July 2007, 18:19 GMT
maybe:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=379400
and
http://packages.debian.org/changelogs/pool/main/x/xinetd/xinetd_2.3.14-1/changelog
will provide some clues. But probably not. Here's an output of strace winecfg:

mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7e4c0000
read(12, "#\t$NetBSD: services,v 1.84 2007/"..., 4096) = 4096
read(12, "89/udp\t\t\t# Lightweight Directory"..., 4096) = 4096
read(12, "e\npostgresql\t5432/udp\t\t# Postgre"..., 4096) = 4096
read(12, "2431/udp\t\t# udp sftp side effect"..., 4096) = 1363
read(12, "", 4096) = 0
close(12) = 0
munmap(0x7e4c0000, 4096) = 0
rt_sigaction(SIGPIPE, {SIG_IGN}, NULL, 8) = 0
access("/dev/random", R_OK) = 0
access("/dev/urandom", R_OK) = 0
open("/dev/urandom", O_RDONLY) = 12
fcntl64(12, F_GETFD) = 0
fcntl64(12, F_SETFD, FD_CLOEXEC) = 0
select(13, [12], NULL, NULL, {3, 0}) = 1 (in [12], left {3, 0})
read(12, "\245\364\344\375\231H\370\35\244i[\25\354\f\346~\221\220"..., 120) = 120
select(13, [12], NULL, NULL, {3, 0}) = 1 (in [12], left {3, 0})
read(12, ":,$\260\246h\346/\342\233\f\353\371\230\255{m\370\6\241"..., 120) = 120
select(13, [12], NULL, NULL, {3, 0}) = 1 (in [12], left {3, 0})
read(12, "\243\17|\272=9\347\6\6\307#\241\1;\316ga\204\rqE\241\32"..., 120) = 120
select(13, [12], NULL, NULL, {3, 0}) = 1 (in [12], left {3, 0})
read(12, "@\322\313v\256\356D\365\233\334q\351\307J\246\33\10\266"..., 120) = 120
select(13, [12], NULL, NULL, {3, 0}) = 1 (in [12], left {3, 0})
read(12, "\17\351\375\334\352\311\v\222\252\304\324~\325\367\27\202"..., 120) = 120
gettimeofday({1184728655, 610810}, NULL) = 0
getrusage(RUSAGE_SELF, {ru_utime={0, 132008}, ru_stime={0, 92005}, ...}) = 0
time(NULL) = 1184728655
times({tms_utime=13, tms_stime=9, tms_cutime=0, tms_cstime=0}) = 1718926550
socket(PF_NETLINK, SOCK_RAW, 0) = 13
bind(13, {sa_family=AF_NETLINK, pid=0, groups=00000000}, 12) = 0
getsockname(13, {sa_family=AF_NETLINK, pid=9866, groups=00000000}, [12]) = 0
time(NULL) = 1184728655
sendto(13, "\24\0\0\0\26\0\1\3O\206\235F\0\0\0\0\0\0\0\0", 20, 0, {sa_family=AF_NETLINK, pid=0, groups=00000000}, 12) = 20
recvmsg(13, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"<\0\0\0\24\0\2\0O\206\235F\212&\0\0\2\30\200\0\3\0\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 60
recvmsg(13, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"@\0\0\0\24\0\2\0O\206\235F\212&\0\0\n@\200\375\3\0\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 64
recvmsg(13, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"\24\0\0\0\3\0\2\0O\206\235F\212&\0\0\0\0\0\0\3\0\0\0\24"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 20
close(13) = 0
socket(PF_FILE, SOCK_STREAM, 0) = 13
fcntl64(13, F_SETFL, O_RDWR|O_NONBLOCK) = 0
connect(13, {sa_family=AF_FILE, path="/var/run/nscd/socket"}, 110) = -1 ENOENT (No such file or directory)
close(13) = 0
socket(PF_FILE, SOCK_STREAM, 0) = 13
fcntl64(13, F_SETFL, O_RDWR|O_NONBLOCK) = 0
connect(13, {sa_family=AF_FILE, path="/var/run/nscd/socket"}, 110) = -1 ENOENT (No such file or directory)
close(13) = 0
open("/etc/resolv.conf", O_RDONLY) = 13
fstat64(13, {st_mode=S_IFREG|0644, st_size=79, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7e4c0000
read(13, "# Generated by dhcpcd for interf"..., 4096) = 79
read(13, "", 4096) = 0
close(13) = 0
munmap(0x7e4c0000, 4096) = 0
open("/etc/hosts", O_RDONLY) = 13
fcntl64(13, F_GETFD) = 0
fcntl64(13, F_SETFD, FD_CLOEXEC) = 0
fstat64(13, {st_mode=S_IFREG|0644, st_size=219, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7e4c0000
read(13, "#\n# /etc/hosts: static lookup ta"..., 4096) = 219
read(13, "", 4096) = 0
close(13) = 0
munmap(0x7e4c0000, 4096) = 0
open("/etc/hosts", O_RDONLY) = 13
fcntl64(13, F_GETFD) = 0
fcntl64(13, F_SETFD, FD_CLOEXEC) = 0
fstat64(13, {st_mode=S_IFREG|0644, st_size=219, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7e4c0000
read(13, "#\n# /etc/hosts: static lookup ta"..., 4096) = 219
close(13) = 0
munmap(0x7e4c0000, 4096) = 0
time(NULL) = 1184728655
socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 13
setsockopt(13, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0
setsockopt(13, SOL_TCP, TCP_NODELAY, [1], 4) = 0
fcntl64(13, F_SETFD, FD_CLOEXEC) = 0
connect(13, {sa_family=AF_INET, sin_port=htons(631), sin_addr=inet_addr("127.0.0.1")}, 16

^ That is where it hangs for some minutes before it continues
Comment by Dale Blount (dale) - Wednesday, 18 July 2007, 12:04 GMT
I'm guessing that's because dhcpcd is setting your system hostname to something that's not in /etc/hosts. Try running `hostname` after you run dhcpcd and then putting that value in /etc/hosts.
Comment by Jan de Groot (JGC) - Wednesday, 18 July 2007, 16:18 GMT
connect(13, {sa_family=AF_INET, sin_port=htons(631), sin_addr=inet_addr("127.0.0.1")}, 16

That's a connection to localhost:631. Looks like something tries to contact cups, but your localhost interface is either down or firewalled.
Comment by kongokris 2 (nut543) - Wednesday, 25 July 2007, 00:00 GMT
hostname gave the same name as the one in /etc/hosts

it's firewalled? i'm not running cups either :/

now i have only

127.0.0.1 localhost

in /etc/hosts

but it still takes a long while to start winecfg/wine apps

Is the error elsewhere?
Comment by kongokris 2 (nut543) - Sunday, 05 August 2007, 19:42 GMT
The reason was that i didn't run the network daemon. I didn't know i had to :) It wasn't in the Official installation guide or the beginners guide during my quick search of those atleast.

Loading...