Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#76074 - Screen stop showing after update to 5.19.12.arch1-1 kernel

Attached to Project: Arch Linux
Opened by Vitalii (cradlemann) - Friday, 30 September 2022, 13:45 GMT
Last edited by Toolybird (Toolybird) - Monday, 03 October 2022, 03:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After updating to 5.19.12.arch1-1 kernel my main laptop screen stop working. Only after reverting to 5.19.11.arch1-1 kernel via chroot my screen start working again

Additional info:
* 5.19.12.arch1-1 kernel
* System hardware info:
$ sudo inxi -bF
System:
Host: Talon-NB020 Kernel: 5.19.11-arch1-1 arch: x86_64 bits: 64
Desktop: sway v: 1.7 Distro: Arch Linux
Machine:
Type: Laptop System: Dell product: XPS 13 9305 v: N/A serial: FRQW0J3
Mobo: Dell model: 0PPYW4 v: A02 serial: /FRQW0J3/CNCMK001A30214/
UEFI: Dell v: 1.0.9 date: 07/20/2021
Battery:
ID-1: BAT0 charge: 50.1 Wh (100.0%) condition: 50.1/52.0 Wh (96.3%)
CPU:
Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
cache: L2: 5 MiB
Speed (MHz): avg: 1678 min/max: 400/4700 cores: 1: 2118 2: 1120 3: 1547
4: 611 5: 1312 6: 2312 7: 1604 8: 2800
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
Display: server: Xwayland v: 22.1.3 driver: gpu: i915 note: X driver n/a
resolution: 1: 2560x1440 2: 3840x2160
Message: GL data unavailable for root.
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.19.11-arch1-1 running: yes
Sound Server-2: PipeWire v: 0.3.58 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlan0 state: up mac: 94:e2:3c:78:f4:42
Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
IF: eth0 state: down mac: a0:ce:c8:68:4b:42
IF-ID-1: br-e6b7e8485fb3 state: down mac: 02:42:a4:27:61:d2
IF-ID-2: docker0 state: down mac: 02:42:20:00:91:9e
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb
Report: bt-adapter ID: hci0 state: up address: 94:E2:3C:78:F4:46
Drives:
Local Storage: total: 534.88 GiB used: 305.2 GiB (57.1%)
ID-1: /dev/mmcblk0 vendor: SanDisk model: SD64G size: 57.94 GiB
ID-2: /dev/nvme0n1 vendor: Samsung model: PM9A1 NVMe 512GB
size: 476.94 GiB
Partition:
ID-1: / size: 468.18 GiB used: 305.13 GiB (65.2%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 196.9 MiB used: 72.3 MiB (36.7%) fs: vfat
dev: /dev/nvme0n1p1


Steps to reproduce:
Update to kernel 5.19.12.arch1-1
This task depends upon

Closed by  Toolybird (Toolybird)
Monday, 03 October 2022, 03:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#76064 
Comment by loqs (loqs) - Friday, 30 September 2022, 14:57 GMT
 FS#76064  ?
Comment by Vitalii (cradlemann) - Friday, 30 September 2022, 15:00 GMT
Yes, the same problem
Comment by Simon Brännström (Sensu) - Saturday, 01 October 2022, 12:21 GMT
From my experience, the screen turns black whenever X is started. I don't use a display manager and I have a .zprofile set to run startx on my xinitrc, which in turn executes my window manager Awesome whenever I sign in with my user account. Starting X manually does not resolve the issue and an attempt to reinstall all xorg packages using "pacman -Syy xorg" did not help either.

However I should mention that I run Xorg and I don't use Wayland or Xwayland at all.

I run an Nvidia RTX 3060 card unlike you, but completing troubleshooting steps in the Arch Wiki still presents the same issue:
https://wiki.archlinux.org/title/NVIDIA/Troubleshooting#Blackscreen_at_X_startup_/_Machine_poweroff_at_X_shutdown

Loading...