Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#76064 - 5.19.12 kernel breaks framework laptop screen

Attached to Project: Arch Linux
Opened by Rohan Bhela (object_Object) - Thursday, 29 September 2022, 19:51 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 04 October 2022, 16:55 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 20
Private No

Details

Description:

On the 5.19.12 kernel, the screen of the framework laptop (and maybe others) doesn't turn on, with the backlight flashing on and off. Downgrading to 5.19.11 fixes it.
Maybe the kernel should be moved back to testing repos?

Steps to reproduce:
Install 5.19.12 and boot
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 04 October 2022, 16:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 5.19.13.arch1-1
Comment by loqs (loqs) - Thursday, 29 September 2022, 19:59 GMT
Please try the two kernels from https://bbs.archlinux.org/viewtopic.php?pid=2059777#p2059777 and see if they both have the issue.
Comment by Rohan Bhela (object_Object) - Friday, 30 September 2022, 00:44 GMT
Ok, it might take some time because I'm in school and kind of swamped with homework. I'll do it on the weekend at the latest.
Comment by loqs (loqs) - Friday, 30 September 2022, 01:09 GMT
[1] is a completed bisect, you could check the last known good from [2] and first known bad [3] see if you get the same results.

[1] https://bbs.archlinux.org/viewtopic.php?pid=2059823#p2059823
[2] https://bbs.archlinux.org/viewtopic.php?pid=2059820#p2059820
[3] https://bbs.archlinux.org/viewtopic.php?pid=2059812#p2059812
Comment by Kelton (kgb33) - Friday, 30 September 2022, 01:59 GMT
Not OP, but I also have the same issue on a framework laptop.

[2]/r4 works correctly
[3]/r5 does not work (backlight flashing)

Thanks & please let me know if you need anything else!
Comment by loqs (loqs) - Friday, 30 September 2022, 02:52 GMT
Try the fix from [1] on any kernel with the issue. Try the kernel from [2] without that fix. [2] reverts the following ( I had to revert the first three commits in order to revert the last one )
git revert -n 0d0f5ca7f241edf07f90599e4e7fadf1ddce97db # drm/i915/display: Fix handling of enable_psr parameter
git revert -n f6bb739e61eb92bad3dcf4c336b91864d51f9503 # drm/i915/dsi: fix dual-link DSI backlight and CABC ports for display 11+
git revert -n d9d2625dafe29324fe01ecba684ce48a70ec322c # drm/i915/dsi: filter invalid backlight and CABC ports
git revert -n fc6aff984b1c63d6b9e54f5eff9cc5ac5840bc8c # drm/i915/bios: Split VBT data into per-panel vs. global parts
[3] 0d0f5ca7f241edf07f90599e4e7fadf1ddce97db looks as though it was intended to fix this issue or a related one introduced by fc6aff984b1c63d6b9e54f5eff9cc5ac5840bc8c.
Edit:
Upstream bug report [4]

[1] https://wiki.archlinux.org/title/intel_graphics#Screen_flickering
[2] https://drive.google.com/file/d/1U6Y5ds--ZM6NI7EVF-H8pJNI3ioPoms-/view?usp=sharing linux-5.19.12-1.1-x86_64.pkg.tar.zst
[2] https://drive.google.com/file/d/10kciG0j-i6I3axwKbsENAw6f_IoQa6GZ/view?usp=sharing linux-headers-5.19.12-1.1-x86_64.pkg.tar.zst
[3] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.19.12&id=0d0f5ca7f241edf07f90599e4e7fadf1ddce97db
[4] https://gitlab.freedesktop.org/drm/intel/-/issues/6993
Comment by Kelton (kgb33) - Friday, 30 September 2022, 04:40 GMT
The fix in [1] (i915.enable_psr=0) did not work. I tested on linux-5.19.12.arch1-1 (the current version in the repos).


[2] (linux-5.19.12-1.1) works as expected. (removed i915.enable_psr=0)


Again, please let me know if you need anything else.
Comment by loqs (loqs) - Friday, 30 September 2022, 05:54 GMT
Upstream would like some additional info in the upstream bug report [1].

[1] https://gitlab.freedesktop.org/drm/intel/-/issues/6993#note_1574768
Comment by Jan Visser (starquake) - Friday, 30 September 2022, 06:57 GMT
I have the same problem with a CLEVO NV41MZ. Is there anything I can do to help? I'm going to do some debugging and try the things you mentioned.
Comment by John Smith (InfamousMower) - Friday, 30 September 2022, 16:20 GMT
I have the same problem, also a Framework 12th gen. I haven't tried downgrading or other fixes, but I'm happy to help if I can.

For what it's worth, connecting an external display seems to mostly work. I can't start KDE, but I can at least get into the system without chrooting.
Comment by TrailingEdge (TrailingEdge) - Friday, 30 September 2022, 17:30 GMT
@loqs Does https://gitlab.freedesktop.org/drm/intel/-/issues/6993 really refer to the same issue? Behavior seems to be a little bit different and the bisected commit is a different one.

I had the same problem with 5.19.12, but building upstream on commit 987a926c1d8a40e4256953b04771fbdb63bc7938 everything is working fine again.
Comment by loqs (loqs) - Friday, 30 September 2022, 18:27 GMT
@TrailingEdge sorry about that could you create the upstream bug report?
Edit:
The alternative would be to wait for 6.0 to become stable and the issue would presumably resolve itself.
Comment by Rohan Bhela (object_Object) - Saturday, 01 October 2022, 01:37 GMT
Shouldn't this kernel be moved back to the testing repos? It seems to break all intel laptops (I've tried booting on my intel school laptop and it's also broken)
Comment by Kelton (kgb33) - Sunday, 02 October 2022, 01:46 GMT
I was working on submitting a bug to upstream but it seems like it's already fixed in their most recent commit(https://cgit.freedesktop.org/drm-tip, fd2f9b9a4178e667adad268a662eb8a9c0ddc8f8).

Between TrailingEdge & I being able to use more recent commits I think the best bet is to wait for 6.0.
Comment by znerk (znerk) - Monday, 03 October 2022, 08:40 GMT
I am having this exact issue on a HP 840 laptop. If the computer wakes from sleep, the screen just flashes on a completely black screen.
Comment by Whitehat BOFH (whitehatbofh) - Tuesday, 04 October 2022, 11:19 GMT
I'm experiencing the same issue on a Dell G15 SE laptop. Rolling back to a kernel before 5.19.12 fixed the issue. (In my case, 5.19.8, since that was the prior version I had when I updated my system and received the buggy 5.19.12 kernel)
Comment by Jan Visser (starquake) - Tuesday, 04 October 2022, 11:30 GMT
My issue is resolved when I tried 6.0.0 using linux-mainline from AUR so I'll be waiting for 6.0.0 to appear in the repo's
Comment by znerk (znerk) - Tuesday, 04 October 2022, 12:54 GMT
so what will be the approach forward now? Do we wait for 6.0.0 or will the bug be sorted in 5.19.12?
Comment by Jan Alexander Steffens (heftig) - Tuesday, 04 October 2022, 12:58 GMT
This hurts enough I'll release another 5.19 kernel before starting on 6.0.
Comment by znerk (znerk) - Tuesday, 04 October 2022, 13:03 GMT
That's great news. Hopefully within a week or something then? What a great community. I am here to stay :)
Comment by Christian Hesse (eworm) - Tuesday, 04 October 2022, 13:49 GMT Comment by Jan Alexander Steffens (heftig) - Tuesday, 04 October 2022, 15:26 GMT
5.19.13 in [testing], please verify it's fixed, if you're able.
Comment by Christian Hesse (eworm) - Tuesday, 04 October 2022, 15:56 GMT
Works for me on Framework with Intel 12th Gen.
Comment by Jan Visser (starquake) - Tuesday, 04 October 2022, 16:24 GMT
Works for me on the Clevo NV41MZ too
Comment by Rohan Bhela (object_Object) - Tuesday, 04 October 2022, 16:38 GMT
Works for me (framework 11th gen)

Loading...