Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#7598 - 2.6.22 showstoppers

Attached to Project: Arch Linux
Opened by Thomas Bächler (brain0) - Tuesday, 10 July 2007, 15:20 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 30 July 2007, 20:34 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


This is a collection of bugs that need to be fixed before 2.6.22 can be moved to current.

- madwifi is broken (kth5 fixed it for x86_64, i686?? please build!)

Closed by  Tobias Powalowski (tpowa)
Monday, 30 July 2007, 20:34 GMT
Reason for closing:  Fixed
Comment by Börje Holmberg (linfan) - Wednesday, 11 July 2007, 09:46 GMT
vmware-modules won't be built for 2.6.22 - instead a /lib/modules/2.6.21 is created.
Comment by Alexander Baldeck (kth5) - Wednesday, 11 July 2007, 14:45 GMT
virtualbox-modules in community also do not work on x86_64. they build but when a machine is started you can find the following in dmesg:

vboxdrv: Trying to deactivate NMI watchdog permanently...
vboxdrv: Successfully done.
general protection fault: 0000 [1] PREEMPT SMP
Modules linked in: vboxdrv nvidia(P) ipv6 usbhid hid ff_memless snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device firewire_ohci firewire_core crc_itu_t snd_pcm_oss snd_mixer_oss snd_hda_intel snd_pcm wlan_scan_sta rtc_cmos rtc_core ath_rate_sample ohci1394 ieee1394 rtc_lib snd_timer snd soundcore snd_page_alloc pcspkr i2c_nforce2 i2c_core k8temp serio_raw ohci_hcd psmouse ath_pci wlan forcedeth ehci_hcd ath_hal(P) tsdev evdev thermal fan button battery ac fuse tun powernow_k8 freq_table processor usbcore ext3 jbd mbcache ide_cd cdrom sd_mod generic sata_nv amd74xx ide_core libata
Pid: 7385, comm: VirtualBox Tainted: P 2.6.22-ARCH #1
RIP: 0010:[<ffffffff888b077a>] [<ffffffff888b077a>] :vboxdrv:g_abExecMemory+0x319a/0x180000
RSP: 0000:ffff81001f2f5f20 EFLAGS: 00010056
RAX: 0000000000001d01 RBX: 0000000000000595 RCX: 00000000c0000080
RDX: 0000000000000000 RSI: 0000000000000d01 RDI: 00002aaaab11b000
RBP: ffff81001f2f5f28 R08: 0000000068747541 R09: 0000000000002001
R10: 0000000001000000 R11: 00000000444d4163 R12: 00002aaaab11b000
R13: 0000000000010004 R14: 00002aaaabc7cb60 R15: 00000000fffffdff
FS: 00000000411c8950(0063) GS:ffff810037ffc340(0000) knlGS:0000000000000000
CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 00002af83b996d10 CR3: 0000000026d33000 CR4: 00000000000006e0
Process VirtualBox (pid: 7385, threadinfo ffff81001f2f4000, task ffff810037e9c900)
Stack: 0000000000000097 ffff81001f2f5fa8 ffffffff888ada57 00002aaaac035390
00002aaaabc7cb60 00000000fffffdff ffffffff8049bfad 00000000fffffdff
00002aaaabc7cb60 00002aaaac035390 00002aaaab5e1000 00000000411c7ef0
Call Trace:
[<ffffffff888ada57>] :vboxdrv:g_abExecMemory+0x477/0x180000
[<ffffffff8049bfad>] error_exit+0x0/0x84
[<ffffffff888ecf66>] :vboxdrv:g_abExecMemory+0x3f986/0x180000

Code: 0f 30 f7 c6 00 10 00 00 0f 84 27 ff ff ff c6 87 c8 dd 00 00
RIP [<ffffffff888b077a>] :vboxdrv:g_abExecMemory+0x319a/0x180000
RSP <ffff81001f2f5f20>
Comment by Alexander Baldeck (kth5) - Wednesday, 11 July 2007, 14:46 GMT
kvm-amd locks up as well when modprobed already.
Comment by Pierre Schmitz (Pierre) - Wednesday, 11 July 2007, 15:32 GMT
vboxdrv works on x86_64 (see ~pierre/packages/src)
Comment by Thomas Bächler (brain0) - Wednesday, 11 July 2007, 15:38 GMT
- vboxdrv works here as well, it was one of my first tests.
- vmware doesn't build for 2.6.22, but there are patches available. if you ask me, use virtualbox, it is always the same trouble with vmware
- can anyone fix kvm? I cannot test it at all. Why don't we use the kvm version shipped with 2.6.22?
Comment by Börje Holmberg (linfan) - Thursday, 12 July 2007, 06:38 GMT
The so called fixes for vmware is just nonsense - i tried all the steps. I guess somebody read about the fix and took it for granted that it should work. Have anybody of you tried it? Or do you just quote what is written on the net :)
Comment by Greg (dolby) - Thursday, 12 July 2007, 07:29 GMT
there also an issue with the linuxtag iso which doesnt generate (at leastutf8) locale correctly. this bug isnt present in the Duke iso
Comment by Attila (attila) - Thursday, 12 July 2007, 11:35 GMT
I suggest to give the kvm modules from the vanilla kernel a try because with kernel 2.6.22 you can use kvm-22 and later. So it seems the time that you have to use a certain version is over. But perhaps my english is too bad and i misunderstood it.-)

Comment by Attila (attila) - Thursday, 12 July 2007, 21:02 GMT
I turn on KVM in the config of my own kernel package 2.6.22 and it works with my core2duo. If anyone with an AMD pc get the same success we can forget making extra kvm-modules packages from my view.
Comment by Bob (Cotton) - Thursday, 12 July 2007, 21:22 GMT
Booting using the pata_sis module leads to timeouts accessing ATA 0 & 1. Appears to try and sort itself out with "soft resets" but just loops very slowly).

Using the kernel26-fallback.img symptoms are identical. Have tried adding legacy_ide earlymodules=sis to the relevant line in grub, to no avail.

This system boots successfully using the stock 2.6.21 kernel (although error message occur during booting when accessing ATA).

Comment by Kristoffer Jan-Olov Tångfelt (revellion) - Thursday, 12 July 2007, 22:27 GMT
there's also a bug with usb-storage or some USB ID mapping in the 2.6.22 package that makes it think my Sarotech external USB2.0 200GB HDD is an input device and therefore loads usbtouchscreen and registers an event device.

worked fine in 2.6.21. but the USB ID of the drive is generally a bit wierd as well being 1234:5678 so dunno if some blacklisting in stock 2.6.22 is to blame.
since this bug is also present in 2 other distro's 2.6.22 packages i've tried(Gentoo,Ubuntu Gutsy).

Jul 13 00:04:44 midera usb 4-3: USB disconnect, address 2
Jul 13 00:15:54 midera usb 4-3: new high speed USB device using ehci_hcd and address 5
Jul 13 00:15:54 midera usb 4-3: configuration #1 chosen from 1 choice
Jul 13 00:15:54 midera input: Sarotech Co., Ltd. Shiny new device as /class/input/input5
the part of dmesg generated when i re-plug the drive back in. on 2.6.21 it goes right over usb-storage's init sequence and finds the 1 partition and the main device node.
Comment by Thomas Bächler (brain0) - Thursday, 12 July 2007, 23:00 GMT
@Cotton: in my experience, pata_sis is still quite unstable. You should use ide and sis5513 driver instead, but you need to boot your system and change mkinitcpio.conf to do that, as well as change all sdX references to hdX in fstab and menu.lst

@revellion: I have never seen such a stupid bug. A usb device knows what it is, and confusing a touchscreen with a hard drive shouldn't happen. There has to be something seriously wrong there.

@attila: Someone in the dev team thought it would be a great idea to build KVM separately, I don't know the reasons. I am not in any position to test it, so I won't be able to fix the bugs until I get a definite answer. But your post suggest that building the kvm version included in linux would be a good idea.
Comment by . (Thralas) - Friday, 13 July 2007, 02:19 GMT
vmware-server-modules builds just fine - though with the patch as described in the AUR comments for vmware-server-modules.
Comment by Attila (attila) - Friday, 13 July 2007, 04:46 GMT
@brain0 This is from the kvm mailing list and stands in the announcement about kvm-29: "Modules from Linux 2.6.22 and up will work with any kvm version from kvm-22.  Some features may only be available in newer releases." This information is only hours old so before this it was be right to use not the kvm modules from vanilla if you want to run the latest version of kvm.
Comment by Pierre Schmitz (Pierre) - Sunday, 15 July 2007, 17:52 GMT
We should have a look at this issue:
Comment by kongokris 2 (nut543) - Monday, 16 July 2007, 11:58 GMT
I couldn't get wifi to work with the newest kernel or maybe it was the newest ndiswrapper... after i downgraded the kernel and ndiswrapper i got it working again.
Comment by Alexander Baldeck (kth5) - Tuesday, 17 July 2007, 14:22 GMT
madwifi should work again. the packages in testing use a snapshot from trunk, patching was far too complicated so i tested my version for a couple of days and all looks fine. please report for i686! i don't have one.
Comment by Dany Martineau (danym) - Wednesday, 18 July 2007, 22:10 GMT
acpi-asus-m6-battery-fix.patch conflicts with custom dsdt file. I have a Toshiba satellite P100 and i must use a custom dsdt file to have sound. Last version of kernel ( introduced acpi-asus-m6-battery-fix.patch. Without the patch, the sound works ok. Note that my sound card is recognized with the patch, but the sound card refuses to play sound.
Comment by dtw (dibblethewrecker) - Thursday, 19 July 2007, 15:03 GMT
I can't see a depends task but madwifi does work on i686
Comment by Thomas Bächler (brain0) - Thursday, 19 July 2007, 15:21 GMT
In that case we should remove the asus battery patch again. Unless a new dsdt-initrd patch fixes the problem.
Comment by kongokris 2 (nut543) - Thursday, 19 July 2007, 18:10 GMT
About my wifi problem: I got it working with the new kernel with bcm43xx so i guess ndiswrapper is not a problem anymore... I do have to connect once(through wifi-radar) then having it fail and on the second try it works, don't know why... maybe it's related to my but in any case you don't have to hold the kernel for me anymore :)
Comment by Dawid Wróbel (cromo) - Monday, 23 July 2007, 23:39 GMT
Any progress on madwifi issue?
Comment by Alexander Baldeck (kth5) - Monday, 23 July 2007, 23:41 GMT
Dunno who it was but somebody on the line of devs had success with the packages I've made from a trunk checkout worked on i686. He hasn't built and uploaded them yet though. I don't have a i686 system to test madwifi with.
Comment by Thomas Bächler (brain0) - Tuesday, 24 July 2007, 14:01 GMT
They have been updated yesterday, if you'd care to look in CVS/on the homepage.
Comment by dtw (dibblethewrecker) - Tuesday, 24 July 2007, 14:24 GMT
kth5 - you did say test - you never said build, test and upload. When I feedback to you I did ask if that was all I needed to do ;-)
Comment by Alexander Baldeck (kth5) - Tuesday, 24 July 2007, 15:03 GMT
dtw - oops... err, well. can you please build it? :)
Comment by Thomas Bächler (brain0) - Wednesday, 25 July 2007, 19:02 GMT
hello? tpowa already built it for i686 days ago ...
Comment by Dawid Wróbel (cromo) - Wednesday, 25 July 2007, 21:54 GMT has made it working here again. Thanks. Seems that this issue is no longer a showstopper.