Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75902 - [glibc] Upgrade 2.36-3 -> 2.36-4 breaks Electron applications

Attached to Project: Arch Linux
Opened by Alexander Popov (AlexWayfer) - Tuesday, 13 September 2022, 22:53 GMT
Last edited by freswa (frederik) - Wednesday, 05 October 2022, 14:36 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To freswa (frederik)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I've upgraded the system. Application like [`atom-editor-beta-bin`](https://aur.archlinux.org/packages/atom-editor-beta-bin) and even [`keeweb`](https://aur.archlinux.org/packages/keeweb), pretty compiled Electron applications, stopped to launch.

The error was like:

```
FATAL:gpu_data_manager_impl_private.cc(415)] GPU process isn't usable.
```

The investigation was not easy, but it ended up with `glibc` (and `lib32-glibc`) very-minor update.

Additional info:
* package version(s): 2.36-4

Steps to reproduce:
* Just upgrade from 2.36-3 to 2.36-4.
* Try to launch some Electron apps, examples above.
This task depends upon

Closed by  freswa (frederik)
Wednesday, 05 October 2022, 14:36 GMT
Reason for closing:  Won't fix
Additional comments about closing:  This is an issue that got patched by upstream electron long time ago.
Comment by Alexander Popov (AlexWayfer) - Tuesday, 13 September 2022, 23:02 GMT
Forgot to add: flags `--no-sandbox` and `--in-process-gpu` (for Electron apps) worked as work-arounds, googled from different projects and old issues, but I don't appreciate such approaches so I've walked to the end of reasons.
Comment by freswa (frederik) - Tuesday, 13 September 2022, 23:04 GMT
Please get in touch with upstream. They are using a very old electron version (<= 12) based on chromium 89 or older.
They need to update electron or apply this patch: https://github.com/electron/electron/commit/993ecb5bdd5c57024c8718ca6203a8f924d6d574
Comment by Alexander Popov (AlexWayfer) - Tuesday, 13 September 2022, 23:13 GMT
@freswa I've got it. Atom Editor is pretty dead, will seeā€¦ about KeeWeb I've left the comment here: https://github.com/keeweb/keeweb/issues/1975#issuecomment-1246040170

Thank you anyway. Sadly that such minor update crashes such amount of apps. As well as outdated dependencies like Electron.
Comment by freswa (frederik) - Tuesday, 13 September 2022, 23:19 GMT
Just for the reference, this is the PR for atom: https://github.com/atom/atom/pull/23540
Comment by Alexander Popov (AlexWayfer) - Tuesday, 13 September 2022, 23:20 GMT
OK, thanks. I've already created an issue in `atom-community` (have not found similar): https://github.com/atom-community/atom/issues/469

Because, again, the Atom officially pretty dead. But let's see. I'll leave a comment there probably.
Comment by Philip de Lisle (brackenhill-mob) - Thursday, 15 September 2022, 08:43 GMT
This issue also affects ExpanDrive. I've tried the package in AUR (which is flagged as out of date) and the latest AppImage from their website (updated on 2022/07/01).

The switches that work with Atom have no effect on ExpanDrive

Any fix/help/advice gratefully received as my company relies on this package for a number of internal projects.
Comment by freswa (frederik) - Thursday, 15 September 2022, 12:50 GMT
Have you tried to use rclone? It's even in the official repos :)
Comment by Philip de Lisle (brackenhill-mob) - Thursday, 15 September 2022, 13:13 GMT
Using rclone now. Started with this then bought ExpanDrive as with multiple actors, files were not being synced correctly.

Loading...