Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75781 - [gnome-software] doesn't depend on gnome-software-packagekit-plugin

Attached to Project: Arch Linux
Opened by Kilo White (cont999) - Saturday, 03 September 2022, 06:03 GMT
Last edited by Toolybird (Toolybird) - Sunday, 04 September 2022, 01:37 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Normally, you'd expect gnome-software to depend on gnome-software-packagekit-plugin, but this was removed in 2018 according to FS#57943. It was said that PackageKit was very unreliable to use instead of pacman. However, I'm requesting a review of that decision and if it still applies in 2022. Is gnome-software-packagekit-plugin still considered unreliable to be removed from gnome-software's dependencies?


Additional info:
* package version(s)
gnome-software 42.4-1
gnome-software-packagekit-plugin 42.4-1
This task depends upon

Closed by  Toolybird (Toolybird)
Sunday, 04 September 2022, 01:37 GMT
Reason for closing:  Won't implement
Comment by Toolybird (Toolybird) - Sunday, 04 September 2022, 01:37 GMT
Nothing has really changed AFAICT. wiki says packagekit is still not recommended [1]. I've notified PM just in case there is grounds for reconsideration.

[1] https://wiki.archlinux.org/title/Pacman/Tips_and_tricks#Graphical

Loading...