Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75669 - [gparted] 1.4.0 crashes after installing exfatprogs

Attached to Project: Arch Linux
Opened by Timm Schlumpp (timm) - Monday, 22 August 2022, 15:01 GMT
Last edited by Toolybird (Toolybird) - Sunday, 28 August 2022, 21:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After installing the optional dependency package exfatprogs, gparted crashes with this output:

GParted 1.4.0
configuration --enable-libparted-dmraid --enable-online-resize
libparted 3.5

** (gpartedbin:2082): ERROR **: 15:56:18.290:
unhandled exception (type std::exception) in signal handler:
what: basic_string::assign: __pos (which is 18446744073709551615) > this->size() (which is 3)

/usr/bin/gparted: line 222: 2082 Trace/breakpoint trap (core dumped) $BASE_CMD

Not sure if this is an upstream problem, sorry if yes.

Additional info:
* package version
gparted-1.4.0-1
exfatprogs-1.1.3-1

* config and/or log files etc.
trace.log ( from `gdb /usr/lib/gparted/gpartedbin` )

from journalctl:
...
systemd-coredump[3295]: Resource limits disable core dumping for process 3256 (gpartedbin).
systemd-coredump[3295]: [🡕] Process 3256 (gpartedbin) of user 0 dumped core.
...

Steps to reproduce:
# pacman -S exfatprogs
# gparted
This task depends upon

Closed by  Toolybird (Toolybird)
Sunday, 28 August 2022, 21:16 GMT
Reason for closing:  None
Additional comments about closing:  Reporter says "Error does not occur anymore. See comment"
Comment by Toolybird (Toolybird) - Wednesday, 24 August 2022, 05:18 GMT
Unfortunately nothing useful in that trace because no debug symbols. You could try recompiling the pkg yourself with debug [1] or wait for the Package Maintainer to do it. Under what environment are you launching gparted (Xorg, Wayland, etc)? How is it acquiring root?

[1] https://wiki.archlinux.org/title/Debugging/Getting_traces#Rebuild_packages
Comment by Timm Schlumpp (timm) - Sunday, 28 August 2022, 13:50 GMT
I tried again today, error does not occur anymore. No upgrades of the mentioned packages (libparted, gparted, exfatprogs) in the meantime.
I don't know what caused the change. Attached file "upgrades.pacman.log" contains list of all package upgrades done since I reported.

@Toolybird:

Root aquired using:
$ sudo gparted

Environment is Xorg:
xorg-server 21.1.4-1

Loading...