Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75644 - [linux] [linux-zen] 5.19+ ignores font set in vconsole.conf

Attached to Project: Arch Linux
Opened by Magnus Boman (katt) - Thursday, 18 August 2022, 13:59 GMT
Last edited by Toolybird (Toolybird) - Friday, 19 August 2022, 22:10 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Ever since upgrading to linux-zen 5.19 (also tried regular linux package), my set font is ignored and instead the default unusably massive font. Setting font with setfont still works fine. Downgrading to 5.18 works, but is obviously not a great solution.


Additional info:
* package version(s) linux 5.19.2.arch1-1 linux-zen 5.19.2.zen1-1 (also happened on 5.19{,.1} but I only now finally looked into it)

* config and/or log files etc.
cat /etc/vconsole.conf
KEYMAP=sv-latin1
FONT=Lat2-Terminus16

Steps to reproduce:
1. Install linux 5.19
2. Set a font in /etc/vconsole.conf
3. Reboot
4. See it being ignored
This task depends upon

Closed by  Toolybird (Toolybird)
Friday, 19 August 2022, 22:10 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Reporter says "Seemingly working as intended, workaround noted on wiki."
Comment by Toolybird (Toolybird) - Friday, 19 August 2022, 03:22 GMT Comment by Magnus Boman (katt) - Friday, 19 August 2022, 08:52 GMT
Adding amdgpu to to MODULES=() in mkinitcpio.conf works, but seems like a cheap workaround. Is this really intended behavior?
Comment by nl6720 (nl6720) - Friday, 19 August 2022, 08:58 GMT Comment by Magnus Boman (katt) - Friday, 19 August 2022, 09:00 GMT
I somehow completely missed that, even though I thought I looked up and down on that page.. Well in that case I guess it's working as intended...

Loading...