Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75615 - [suil] 0.10.16-1 breaks LV2 plugin GUIs in Ardour

Attached to Project: Community Packages
Opened by maxigaz (maxigaz) - Monday, 15 August 2022, 18:01 GMT
Last edited by David Runge (dvzrv) - Tuesday, 16 August 2022, 13:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When suil 0.10.16-1 is installed, GUI windows of LV2 based plugins do not appear in Ardour 6.9 (installed as ardour from community). Instead, the following error message is printed in Ardour's terminal output:

```
suil error: Failed to open module /usr/local/lib/suil-0/libsuil_x11_in_gtk2.so (/usr/local/lib/suil-0/libsuil_x11_in_gtk2.so: cannot open shared object file: No such file or directory)
```

Steps to reproduce:
1. Open a session in Ardour.
2. Add an LV2 plugin to a track.
3. Double click on the plugin's name in the Editor Mixer (can be toggled with Shift+E).

Additional info:
* Package version(s): suil 0.10.16-1, ardour 6.9-5
* Upstream bug report: https://gitlab.com/lv2/suil/-/issues/5
* Under the upstream bug report, it was suggested that I report this here as well, and also that the right value needs to be passed on to meson inside PKGBUILD.
* The issue does not occur with suil 0.10.12-2.
This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 16 August 2022, 13:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with suil 0.10.16-2 by re-adding gtk2 support.
Comment by Toolybird (Toolybird) - Tuesday, 16 August 2022, 03:17 GMT
> the right value needs to be passed on to meson

As already mentioned in the upstream report, arch-meson is passing "--prefix /usr", so that's not the cause. Checking with "strings", there is no reference to "local" at all in the suil binary pkg. Something else is going on here... Also, GTK2 support was removed in latest Arch update so where is the reference to "libsuil_x11_in_gtk2.so" coming from?

It appears your system might be polluted with some local and/or AUR rubbish?

Comment by Peter Semiletov (semiletov) - Tuesday, 16 August 2022, 11:29 GMT
Ardour reports that libsuil_x11_in_gtk2 is needed for GUI of LV2 versions of SurgeXT (AUR) and ZynAddSubFX (community repo).
Reaper opens GUI of the same plugins fine.
Comment by Peter Semiletov (semiletov) - Tuesday, 16 August 2022, 11:35 GMT
It affects also Helm and I suppose some other important LV2 plugins.
Comment by maxigaz (maxigaz) - Tuesday, 16 August 2022, 12:25 GMT
> It appears your system might be polluted with some local and/or AUR rubbish?

Well, everything is installed either through pacman or paru. I checked the output of pacman -Qm and removed a single AUR package that might be even remotely related (surge-xt-bin), but the results are the same.

> GTK2 support was removed in latest Arch update

So, that is why libsuil_x11_in_gtk2.so is missing from 0.10.16-1, even though Ardour needs it.
Comment by mylofy (mylofy) - Tuesday, 16 August 2022, 13:00 GMT
I can reproduce after updating to suil-0.10.16-1 yesterday with the community binaries of ardour. No issue with the official binaries.
Comment by David Runge (dvzrv) - Tuesday, 16 August 2022, 13:06 GMT
I have removed the gtk2 capability in suil, as we are about to deprecate gtk2 support in many places.
I was not aware this would affect ardour directly. Will have a look.
Comment by David Runge (dvzrv) - Tuesday, 16 August 2022, 13:28 GMT
Hm, the only thing I can do is to build suil again with gtk2 support.
It's very unfortunate that ardour's upstream is not working at all on getting rid of the gtk2 dependency. This way ardour will eventually be removed from the repositories and also require a substantial build overhead in the AUR (e.g. custom suil version), making it disappear into obscurity (aka. manual website downloads only).

Loading...