Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7545 - SSH daemon refusing connections

Attached to Project: Arch Linux
Opened by Maciej Sitarz (macieks2) - Sunday, 01 July 2007, 17:26 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 30 July 2007, 20:35 GMT
Task Type Feature Request
Category Installation
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When trying to install Arch via SSH one needs to:
- bring up the network ( it's normal )
- add "SSHD: ALL" to /etc/hosts.allow ( I think it should be added as default)
- set root password ( I think it's good, mayby a generated for every ISO boot, and showed on screen. It would be more clever :) )

Additional info:
* 2007.05 Duke Installation ISO

Steps to reproduce:
1. Boot the iso
2. bring up the network
3. try to ssh onto the machine with booted ISO
This task depends upon

This task blocks these from closing
 FS#7410 - Post Duke Installation ISO bugs and feature requests 
Closed by  Tobias Powalowski (tpowa)
Monday, 30 July 2007, 20:35 GMT
Reason for closing:  Fixed
Comment by Maciej Sitarz (macieks2) - Sunday, 01 July 2007, 17:32 GMT
After finally connecting to booted ISO, I run /arch/setup and get:

Error opening terminal: xterm-color.

and infinite loop showing this message, I tried to use Eterm and konsole (KDE).
Comment by Maciej Sitarz (macieks2) - Sunday, 01 July 2007, 17:38 GMT
I got it finally working like this:

TERM=linux /arch/setup

but then I can't run screen:

[Arch Linux: /]# screen
Cannot find terminfo entry for 'xterm-color'.

So I must run:
TERM=linux screen

But then:
TERM=linux /arch/setup
looks like crap :) all dialog backgrounds are black, only under text there's background color. ( like in scr_sht1.png uploaded )
Comment by Maciej Sitarz (macieks2) - Sunday, 01 July 2007, 17:39 GMT
Screenshot
Comment by Maciej Sitarz (macieks2) - Sunday, 01 July 2007, 17:42 GMT
Trying to add another screen shot... The previous one is broken
Comment by Maciej Sitarz (macieks2) - Sunday, 01 July 2007, 18:36 GMT
Also there's no /usr/lib/ssh/sftp-server ( no /usr/lib/ssh/ directory ! )
So it's not possible to upload a file using scp, downloading works.

Line
"Subsystem sftp /usr/lib/ssh/sftp-server"
should be removed from sshd_config file, or that directory should exist, IMVHO.
Comment by Roman Kyrylych (Romashka) - Monday, 02 July 2007, 09:36 GMT
Why would we want to allow to ssh from any host on intall iso system _by_default_?
Comment by Maciej Sitarz (macieks2) - Monday, 02 July 2007, 10:22 GMT
So someone can install somebody Arch via net, the 'lame' person needs only to start the install iso, and bring up the network.
Further installation can be done by the person via net.
Comment by Roman Kyrylych (Romashka) - Monday, 02 July 2007, 10:29 GMT
Then probably this should be an option in installer, but not default. (that's insecure :P).
Comment by Tobias Powalowski (tpowa) - Tuesday, 03 July 2007, 21:19 GMT
try the linuxtag isos they should fix imho the problem if not then try these ones:
http://www.archlinux.org/~tpowa/rc-iso/
Comment by Tobias Powalowski (tpowa) - Tuesday, 03 July 2007, 21:32 GMT
the TERM= issue is solved and it's not wanted to have ssh access by default, you can use the pre config option via usb stick to configure ssh as you need it

Loading...