Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75425 - [pageedit] 1.9.10-1 does not open any file

Attached to Project: Community Packages
Opened by Ralf Kuehn (derarchuser) - Tuesday, 26 July 2022, 07:45 GMT
Last edited by Toolybird (Toolybird) - Wednesday, 27 July 2022, 03:24 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Caleb Maclennan (alerque)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description: pageedit-1.9.10-1


Steps to reproduce:

The opened file is not displayed nor any opening works - downgrading to 1.7.0 works fine

$ sudo pacman -U pageedit-1.7.0-1-x86_64.pkg.tar.zst

(1.9.10-1 started in terminal)
$ pageedit

Info:

GL Type: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 4.6
QSG RHI Backend: OpenGL
Using Supported QSG Backend: yes
Using Software Dynamic GL: no
Using Multithreaded OpenGL: yes

Init Parameters:
* application-name pageedit
* browser-subprocess-path /usr/lib/qt6/QtWebEngineProcess
* create-default-gl-context
* disable-features ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture
* disable-setuid-sandbox
* disable-speech-api
* enable-features NetworkServiceInProcess,TracingServiceInProcess
* enable-threaded-compositing
* in-process-gpu
* use-gl desktop
This task depends upon

Comment by Toolybird (Toolybird) - Wednesday, 27 July 2022, 03:23 GMT
There is not much info to go on here.. Have you reported it upstream? It appears we switched to qt6 at last update so maybe that's the problem.
Comment by Caleb Maclennan (alerque) - Monday, 22 August 2022, 11:18 GMT
Running from a Terminal to see output, I see:

Debug: Warning: URLInterceptor blocking access to url ... file:///<the file I opened> ...

This looks like an upstream bug to me or possibly some QT dependency missing or miss-configured. I'm not sure which though. If anybody can dig in further and either report this to the right place or come up with a fix I'll be happy to implement it in the packaging, but I'm unlikely to be able to do so myself in a timely manner.

Loading...