Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75386 - [linux-zen] compile with CONFIG_OVERLAY_FS=y (or =m)

Attached to Project: Arch Linux
Opened by Ray Redondo (raydredondo) - Thursday, 21 July 2022, 01:51 GMT
Last edited by Toolybird (Toolybird) - Thursday, 21 July 2022, 21:49 GMT
Task Type Feature Request
Category Kernel
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

One program I use, Darling, expects to be able to create an overlayfs for the prefix. Currently, it is unable to do that under the zen kernel; after checking in a couple of places, overlayfs doesn't seem to be enabled.

As Darling seems likely to be more used in the future (having macOS tooling and programs on Linux would be very helpful), it would make sense to support what Darling needs.
This task depends upon

Closed by  Toolybird (Toolybird)
Thursday, 21 July 2022, 21:49 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Report made in error
Comment by loqs (loqs) - Thursday, 21 July 2022, 03:39 GMT
linux-zen already already has CONFIG_OVERLAY_FS=m [1] and ships overlay.ko.zst

[1] https://github.com/archlinux/svntogit-packages/blob/packages/linux-zen/trunk/config#L9900
Comment by Ray Redondo (raydredondo) - Thursday, 21 July 2022, 12:10 GMT
Turns out the issue was me not having rebooted since updating my kernel; sorry for the confusion.

Loading...