Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7537 - Missin usleep for package pm-utils

Attached to Project: Arch Linux
Opened by Maciej Sitarz (macieks2) - Saturday, 30 June 2007, 21:18 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 26 December 2007, 14:29 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Low
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Scripts from package pm-utils uses usleep binary which is not in system mayby it's in other package but there's no dependency for it in pm-utils PKGBUILD.

Additional info:
* pm-utils 0.99.3-1
# grep -iR usleep /usr/lib/pm-utils/
/usr/lib/pm-utils/sleep.d/99video: usleep 100000
/usr/lib/pm-utils/functions: openvt -- sh -c "usleep $1 ; rm -f /.suspended >/dev/null 2>&1 0<&1" >/dev/null 2>&1 0<&1 &

Steps to reproduce:
1. run pm-suspend or pm-hibernate
2. go to VT 8 (or other not sure) and search for that message
( could be done after resume from hibernation/suspension)
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 26 December 2007, 14:29 GMT
Reason for closing:  Fixed
Comment by Maciej Sitarz (macieks2) - Sunday, 01 July 2007, 15:18 GMT
I found that another binary is missing, checking /var/log/pm-suspend.log shows:

===== N, 1 VII 2007, 16:41:55 CEST: running hook: /usr/lib/pm-utils/sleep.d/60sysfont =====
/usr/lib/pm-utils/sleep.d/60sysfont: line 7: setsysfont: command not found

$ which setsysfont
which: no setsysfont in (/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/opt/bin:/opt/eclipse:/opt/gnome/bin:/opt/java/bin:/opt/java/jre/bin:/opt/kde/bin:/opt/mozilla/bin:/opt/qt/bin)
Comment by Jan de Groot (JGC) - Sunday, 01 July 2007, 23:17 GMT
It looks like setsysfont is the same thing we do on bootup to set the terminal font. Will come up with a fixed package soon. Please add more of these things when you encounter them.
Comment by name withheld (Gullible Jones) - Monday, 02 July 2007, 01:57 GMT
Hey... I think the setsysfont thing may be why there's no console coming out of suspend, unless you use the framebuffer. Just FWIW.
Comment by name withheld (Gullible Jones) - Monday, 29 October 2007, 09:15 GMT
  • Field changed: Percent Complete (100% → 0%)
Not fixed - 60sysfont still uses setsysfont, and pm-utils still does not depend on whatever provides it.
Comment by Aaron Griffin (phrakture) - Monday, 29 October 2007, 18:41 GMT
IIRC this is the 'kbd' package.
Comment by name withheld (Gullible Jones) - Monday, 29 October 2007, 19:22 GMT
Got that installed... Nope, it isn't in there:

$ pacman -Ql kbd | grep bin
kbd /bin/loadkeys
kbd /bin/loadkeys.static
kbd /usr/bin/chvt
kbd /usr/bin/deallocvt
kbd /usr/bin/dumpkeys
kbd /usr/bin/dumpkeys.static
kbd /usr/bin/fgconsole
kbd /usr/bin/getkeycodes
kbd /usr/bin/kbd_mode
kbd /usr/bin/kbd_mode.static
kbd /usr/bin/kbdrate
kbd /usr/bin/loadunimap
kbd /usr/bin/mapscrn
kbd /usr/bin/openvt
kbd /usr/bin/psfaddtable
kbd /usr/bin/psfgettable
kbd /usr/bin/psfstriptable
kbd /usr/bin/psfxtable
kbd /usr/bin/resizecons
kbd /usr/bin/setfont
kbd /usr/bin/setfont.static
kbd /usr/bin/setkeycodes
kbd /usr/bin/setleds
kbd /usr/bin/setmetamode
kbd /usr/bin/showconsolefont
kbd /usr/bin/showkey
kbd /usr/bin/unicode_start
kbd /usr/bin/unicode_stop
Comment by Aaron Griffin (phrakture) - Monday, 29 October 2007, 22:42 GMT
My mistake. Looks like setsysfont is not distro agnostic (it's a RedHatism). And it does, in a way, what we do in rc.sysinit.

Here's one example:
http://cvsweb.openwall.com/cgi/cvsweb.cgi/Owl/packages/kbd/setsysfont?rev=1.4;content-type=text%2Fplain

We have two options:
a) add a script like this to the kbd package that uses rc.conf and the like
b) patch pm-utils

Either way we _should_ contact the pm-utils people and let them know about this.
Comment by Maciej Sitarz (macieks2) - Monday, 29 October 2007, 23:08 GMT
I'm not sure if I should ask here...
What about using s2disk/s2ram? (from suspend package) A userspace tools for suspending.
kernel26suspend2 is no longer being developed, and pm-utils doesn't use s2disk/ram.
Comment by name withheld (Gullible Jones) - Tuesday, 30 October 2007, 00:58 GMT
Those may be useful to some people but they aren't pm-utils, and they don't offer the same level of functionality.
Comment by name withheld (Gullible Jones) - Tuesday, 30 October 2007, 01:03 GMT
@phrakture: I wonder if pm-utils' RedHat-centric aspects are also responsible for some of the weird behavior of daemons noted here:

http://bugs.archlinux.org/task/8307

This might bear some more looking into methinks.
Comment by Maciej Sitarz (macieks2) - Sunday, 16 December 2007, 12:27 GMT
pm-utils package should depend on vbetool packages, because pm-utilis uses this binary.

Loading...