Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75331 - [open-vm-tools] 6:12.0.5-1 breaks vmware host integration after update to KDE Plasma 5.25

Attached to Project: Community Packages
Opened by Axel Kellermann (akellerm_ment) - Friday, 15 July 2022, 10:37 GMT
Last edited by Toolybird (Toolybird) - Sunday, 24 July 2022, 03:07 GMT
Task Type Bug Report
Category Upstream Bugs
Status Assigned
Assigned To Christian Hesse (eworm)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:

I run an Arch guest on VMWare Workstation Pro 16.2.3 on a Windows 10 20H2 system. Since the update to KDE Plasma 5.25 host integration via open-vm-tools is broken. Both drag and drop operations to/from the host and exchange of clipboard data aren't working anymore.
See the associated KDE bug here: https://bugs.kde.org/show_bug.cgi?id=456008

According to Brennan Kinney's response in the KDE bug, this is related to Plasma switching to systemd for startup. An upstream bug already exists and can be found at https://github.com/vmware/open-vm-tools/issues/568#issuecomment-1178736806.

The reason I'm entering this bug anyway is that Fedora apparently fixed the issue by adding their own startup script to work around the problem. Should Arch adopt this change or wait for a "proper" upstream fix?


Additional info:
* package version(s)
open-vm-tools 6:12.0.5-1
* link to upstream bug report, if any
https://bugs.kde.org/show_bug.cgi?id=456008
https://github.com/vmware/open-vm-tools/issues/568#issuecomment-1178736806

Steps to reproduce:
This task depends upon

Comment by Axel Kellermann (akellerm_ment) - Friday, 15 July 2022, 11:21 GMT
Sorry, I referred to the wrong distro that already has a fix for the issue. It's openSUSE that replaces vmware-user-suid-wrapper with a custom script called vmware-user-autostart-wrapper to make host integration work. More details are in the upstream bug report.
https://github.com/vmware/open-vm-tools/issues/568#issuecomment-1178736806
Comment by Toolybird (Toolybird) - Wednesday, 07 September 2022, 04:58 GMT
Dupe  FS#75825 

Loading...