Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75273 - [jenkins] jdk 8 from config rejected by jenkins

Attached to Project: Community Packages
Opened by Jacob Skoog (agryphos) - Friday, 08 July 2022, 10:11 GMT
Last edited by Toolybird (Toolybird) - Friday, 15 July 2022, 21:02 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Filipe LaĆ­ns (FFY00)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: /etc/conf.d/jenkins defaults to using jdk 8

The config file tries to use jdk 8, but the jenkins 2.358-1 seems to reject jdk 8 and requires jdk 11 or 17.


Additional info:
* package version(s) = 2.358-1
* config and/or log files etc.
* link to upstream bug report, if any
* previously installed packages: jdk 18

Steps to reproduce:
- Install jenkins with `sudo pacman -S jenkins` (also installs jdk 11)
- Try to run with `sudo systemctl start jenkins`
- Get error complaining that jdk 8 doesn't exist
- Install jdk 8
- Try to run again
- Shuts down because it rejects jdk 8

Fix:
- Edit /etc/conf.d/jenkins "JAVA=/usr/lib/jvm/java-8-openjdk/bin/jre/java" to "JAVA=/usr/lib/jvm/java-{11/17}-openjdk/bin/java"
This task depends upon

Closed by  Toolybird (Toolybird)
Friday, 15 July 2022, 21:02 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#74853

Loading...