Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75225 - [home-assistant] fails to start due to not being able to install dependencies

Attached to Project: Community Packages
Opened by Daniel Hahler (blueyed) - Sunday, 03 July 2022, 19:25 GMT
Last edited by Chih-Hsuan Yen (yan12125) - Monday, 04 July 2022, 10:39 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

home-assistant fails to start:

Jul 03 20:50:22 host systemd[1]: Started Home assistant.
Jul 03 20:50:25 host hass[1725452]: 2022-07-03 20:50:25 ERROR (SyncWorker_1) [homeassistant.util.package] Unable to install package pyotp==2.6.0: ERROR: Could not install packages due to an OSError: [Errno 30] Read-only file system: '/lib/python3.10/site-packages/pyotp'
Jul 03 20:50:27 host hass[1725452]: 2022-07-03 20:50:27 ERROR (SyncWorker_0) [homeassistant.util.package] Unable to install package pyotp==2.6.0: ERROR: Could not install packages due to an OSError: [Errno 30] Read-only file system: '/lib/python3.10/site-packages/pyotp'
Jul 03 20:50:29 host hass[1725452]: 2022-07-03 20:50:29 ERROR (SyncWorker_1) [homeassistant.util.package] Unable to install package pyotp==2.6.0: ERROR: Could not install packages due to an OSError: [Errno 30] Read-only file system: '/lib/python3.10/site-packages/pyotp'
Jul 03 20:50:29 host hass[1725452]: 2022-07-03 20:50:29 ERROR (MainThread) [homeassistant.bootstrap] Home Assistant core failed to initialize. Further initialization aborted
Jul 03 20:50:29 host hass[1725452]: 2022-07-03 20:50:29 WARNING (MainThread) [homeassistant.bootstrap] Unable to set up core integrations. Activating safe mode
Jul 03 20:50:29 host hass[1725452]: 2022-07-03 20:50:29 ERROR (MainThread) [homeassistant.bootstrap] Home Assistant core failed to initialize. Further initialization aborted

Installing python-pyotp and then python-pyqrcode manually (which could be added as deps), it then fails due to the sqlalchemy dependency not being satisfied (wanting sqlalchemy==1.4.37), and more similar issues.

There's nothing mentioned on https://wiki.archlinux.org/title/Home_Assistant in this regard.

Additional info:
* package version(s): 1:2022.6.7-1

Steps to reproduce:
1. Install home-assistant
2. Start the service
This task depends upon

Closed by  Chih-Hsuan Yen (yan12125)
Monday, 04 July 2022, 10:39 GMT
Reason for closing:  Duplicate
Additional comments about closing:  https://bugs.archlinux.org/task/75204

Loading...