Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75205 - firefox crashes on start after system update

Attached to Project: Arch Linux
Opened by Rainer Schaue (void42) - Friday, 01 July 2022, 06:25 GMT
Last edited by Jonas Witschel (diabonas) - Sunday, 03 July 2022, 09:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
After yesterdays update firefox crashes at startup for me (firefox crash dialog)

Additional info:
* firefox-102.0-1 (downgrading does not help, tried 101.0.1-1 and 100.0-1)

* Update was:

[2022-06-30T19:44:43+0200] [ALPM] transaction started
[2022-06-30T19:44:43+0200] [ALPM] upgraded argyllcms (2.3.0-1 -> 2.3.1-1)
[2022-06-30T19:44:44+0200] [ALPM] upgraded cardinal-data (22.05-1 -> 22.06-1)
[2022-06-30T19:44:44+0200] [ALPM] upgraded sqlite (3.38.5-1 -> 3.39.0-2)
[2022-06-30T19:44:44+0200] [ALPM] upgraded harfbuzz (4.4.0-1 -> 4.4.1-1)
[2022-06-30T19:44:44+0200] [ALPM] upgraded qt5-base (5.15.5+kde+r163-1 -> 5.15.5+kde+r166-1)
[2022-06-30T19:44:45+0200] [ALPM] upgraded cardinal-vst3 (22.05-1 -> 22.06-1)
[2022-06-30T19:44:45+0200] [ALPM] upgraded glib-networking (1:2.72.0-1 -> 1:2.72.1-1)
[2022-06-30T19:44:45+0200] [ALPM] upgraded harfbuzz-icu (4.4.0-1 -> 4.4.1-1)
[2022-06-30T19:44:45+0200] [ALPM] upgraded lib32-glib-networking (2.72.0-1 -> 2.72.1-1)
[2022-06-30T19:44:45+0200] [ALPM] upgraded lib32-harfbuzz (4.4.0-1 -> 4.4.1-1)
[2022-06-30T19:44:45+0200] [ALPM] upgraded libva (2.14.0-1 -> 2.15.0-1)
[2022-06-30T19:44:45+0200] [ALPM] upgraded libvpx (1.11.0-2 -> 1.12.0-1)
[2022-06-30T19:44:46+0200] [ALPM] upgraded npm (8.6.0-1 -> 8.9.0-1)
[2022-06-30T19:44:46+0200] [ALPM] upgraded python-resolvelib (0.5.5-4 -> 0.8.1-1)
[2022-06-30T19:44:46+0200] [ALPM] installed python-commonmark (0.9.1-5)
[2022-06-30T19:44:46+0200] [ALPM] upgraded python-trove-classifiers (2022.6.23-1 -> 2022.6.26-1)
[2022-06-30T19:44:46+0200] [ALPM] installed python-rich (12.4.4-1)
[2022-06-30T19:44:46+0200] [ALPM] installed python-tenacity (8.0.1-3)
[2022-06-30T19:44:46+0200] [ALPM] upgraded python-pip (21.0-1 -> 22.1.2-1)
[2022-06-30T19:44:46+0200] [ALPM] upgraded python-setuptools-scm (6.4.2-1 -> 7.0.3-1)
[2022-06-30T19:44:46+0200] [ALPM] upgraded vim-runtime (8.2.5046-2 -> 9.0.0000-1)
[2022-06-30T19:44:46+0200] [ALPM] upgraded vim (8.2.5046-2 -> 9.0.0000-1)
[2022-06-30T19:44:46+0200] [ALPM] transaction completed

* Firefox console output:

Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm
Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs

ExceptionHandler::GenerateDump cloned child 3320
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

* Firefox crash dialog details:
AdapterDeviceID: 0x1b81
AdapterDriverVendor: nvidia/unknown
AdapterDriverVersion: 515.48.7.0
AdapterVendorID: 0x10de
AvailablePageFile: 26986266624
AvailablePhysicalMemory: 12065173504
AvailableSwapMemory: 28925317120
AvailableVirtualMemory: 14079905792
BackgroundTaskMode: 0
BuildID: 20220627181515
CrashTime: 1656656617
DesktopEnvironment: kde
HeadlessMode: 0
InstallTime: 1656481611
IsWayland: 0
Notes: Arch LinuxFP(D00-L1000-W00000000-T000)
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SafeMode: 1
SecondsSinceLastCrash: 242
StartupCrash: 1
StartupTime: 1656656617
SubmittedFrom: Client
TelemetrySessionId: 6bd0e19e-78b7-4813-bfec-4f98d37e0a6e
Throttleable: 1
TotalPageFile: 45642641408
TotalPhysicalMemory: 16717324288
UptimeTS: .350037
Vendor: Mozilla
Version: 102.0

This report also contains technical information about the state of the application when it crashed.
This task depends upon

Closed by  Jonas Witschel (diabonas)
Sunday, 03 July 2022, 09:45 GMT
Reason for closing:  Not a bug
Additional comments about closing:  According to the reporter: "Firefox starts with a fresh profile. Probably the profile got damaged somehow."
Comment by Damian Anlauf (Danlauf) - Friday, 01 July 2022, 11:26 GMT
I'm having the same issue. It seems to be related to VA-API video decoding, as after removing `user_pref("media.ffmpeg.vaapi.enabled", true);` from "prefs.js" found inside the Firefox profile directory, it works again.

Maybe it was caused by the libvpx update?
Comment by Archu Ser (axb) - Saturday, 02 July 2022, 02:56 GMT
I'm getting this same issue since 102. After trying Damian's suggestion Firefox now launches again (thank you for that). If I set media.ffmpeg.vaapi.enabled to True Firefox will revert to crashing on startup

Loading...