Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7513 - X freezes

Attached to Project: Arch Linux
Opened by Urs Wolfer (uwolfer) - Monday, 25 June 2007, 14:47 GMT
Last edited by Alexander Baldeck (kth5) - Friday, 09 November 2007, 14:49 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Eric Belanger (Snowman)
Alexander Baldeck (kth5)
Architecture All
Severity Critical
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Some users have the problem that the X server freezes from time to time.

Please see this form thread for more information:
http://bbs.archlinux.org/viewtopic.php?id=34369

This problem happens with nvidia driver for me. I think I have also had this problem once wiht my macbook, which has AFAIK i810 drives.
This task depends upon

This task blocks these from closing
 FS#7920 - xorg showstopper 
Closed by  Alexander Baldeck (kth5)
Friday, 09 November 2007, 14:49 GMT
Reason for closing:  Works for me
Additional comments about closing:  Now that X.org 7.3 has been moved to [extra], more precise input on issues in needed again. Please open more specific bugs.
Comment by arnuld (arnuld) - Monday, 25 June 2007, 15:17 GMT
i also have the same problem. actually i am the one who started that thread :-) and my whole problem is described there. Xorg lockups only occur on Arch and Gentoo. i have used CRUX and Debian for a longer time and never had any lock-ups, not even with Debian Sid (Lenny). here is my hardware:

AMD64 Athlon
ASUS K8V-MX with chipsets VIA K8M800 and VIA VT8237
2x512 DDR 400 MHz RAM
ATA 80GB SAMSUNG
17'' SAMSUNG SyncMaster 793s monitor

i use VIA drivers for X


Comment by Blaž Tomažič (billy) - Monday, 25 June 2007, 17:19 GMT
I have a similar problem with X freezing every now and then. The only thing i can do is to move a mouse, listen to mpd and hard reboot. there is no response from clicking and typing (not even ctrl+alt+backspace or ctrl+alt+Fx) Here are my specs:

32-bit arch linux
Intel Core 2 Duo T7200
256MB ATI MOBILITY RADEON X1400 (fglrx)
2x512 667MHz DDR2 SDRAM

recently i installed xorg 1.3.0 and i don't remember if i had a lockup since then. i'll let you know if it freezes again.
Comment by Catalin Iacob (cataliniacob) - Tuesday, 26 June 2007, 13:29 GMT
Same thing for me. Yesterday it occured twice. I have an Asus laptop with ATI X1600 using proprietary fglrx.

The thread on the forum talks about 2 problems:
#1) when running "X" EVERYTHING just freezes. C-M-F2(3,4 rtc) does not work, my computer gets locked up. the only option is to use "restart" button on Cabinet.

#2) exactly same as #1 but this time mouse moved, i mean mouse pointer does not freeze. but again, the solution is same as the #1.

Exactly problem #2 occured to me yesterday twice at random moments.
Exactly problem #1 occured yesterday two times out of three when trying to start wine so this one seems to be reproducible.
The things above happen while I'm working on my computer.

But for a few weeks now I have a similar problem when kdm asks me to login. I cannot write my password because there is no response to keyboard input. The mouse moves fine. I can also click the buttons in kdm(this is different from #2 above since there clicking the buttons has no effect) but if I choose restart from kdm options it freezes.This is quite rare (say once every 20 - 30 reboots).

I'm not sure if the 3 above are related since there are subtle differences but I reported them hoping that it would help the devs figuring out what's the problem.
Comment by Satchmo (Satchmo) - Tuesday, 26 June 2007, 16:13 GMT
Same problem here (nvidia 7300LE) after updating to the latest X and nvidia 100.14.11-1 (no problem before). The system freezes completely, I can't kill X nor switch to a terminal; only reset.
Maybe a bug in nvidia proprietary drivers?
Comment by Greg Meyer (oggb4mp3) - Wednesday, 27 June 2007, 03:27 GMT
I am experiencing two distinct X freezing issues that it seems people are describing here, and I am not sure which one this bug report has ended up to be about, so I will post both experiences

I also had hard freezes begin to appear when I upgraded to nvidia 100.14.11. The machine completely freezes with no log message. I can't even ssh into the box. I rolled back to 100.14.09 and they appear to have stopped.

I will also say that I am experiencing the other X freezing that people are complaining about. The mouse still moves, but does appear to interact with any elements on the screen. This problem seems to present itself after the computer has been idle for some time. I have a dual-core proc and I can ssh in to the box and look at the CPU stats in htop while this is going on, the two cores sitch back and forth on high cpu usage. Core0 will show the x process at 90+% cpu for a couple of seconds, then core1 will take on the load, then core0, etc. If you wait long enough, it seems that the system actually is responding to mouse clicks, just very slowly. One time I left the machine alone for about fifteen minutes and it appeared to have stopped, although I have not been able to recreate this.

I have tried to look for a pattern based on which apps were left open, whether beryl was running or not, etc. and I can't seem to find a common denominator other than it usually is occurring when I sit down at the machine after being away for some time.
Comment by Greg Meyer (oggb4mp3) - Wednesday, 27 June 2007, 03:52 GMT
I forgot some key hardware specs

AMD Athlon64 X2 5600+
Video Card = NVIDIA GeForce 7300 GS
chipset = NVIDIA nforce5 (MCP55)
Comment by Greg Meyer (oggb4mp3) - Wednesday, 27 June 2007, 12:56 GMT
I forgot some key hardware specs

AMD Athlon64 X2 5600+
Video Card = NVIDIA GeForce 7300 GS
chipset = NVIDIA nforce5 (MCP55)
Comment by Greg Meyer (oggb4mp3) - Friday, 29 June 2007, 02:12 GMT
I have some more info for my second problem, the one where X causes the high CPU usage and appears frozen.

It has happened 2x in the past two days, both times after coming back from being away. When I sat down, the high cpu usage was going on and had been for awhile based on my cpu usage meter. I am using the xorg-server from testing btw, in fact, my whole box runs testing and is up to date.

The programs running when this occurred were different each time.

yesterday
KDE, Beryl running but not active, kwalett, superkaramba and kmix were active in the tray. open apps were Opera, Amarok, Skype, Kmail and vmware had a windowsXP session running.

Today
KDE, Beryl running but not active, kwalett, superkaramba and kmix were active in the tray. open apps were Opera, Firefox and Konqueror.

I am going to try now without kdm loaded, to see if that has anything to do with it, and perhaps I should try rolling back the xorg-server. I wish I could trigger this bug at will so it would be easier to test various combinations.

Also, my logs show nothing, and I tried to attach gdb to the session and get a backtrace, but it is useless because of the stripped binaries.
Comment by Jan de Groot (JGC) - Friday, 29 June 2007, 07:25 GMT
"Beryl running but not active".. could you disable beryl completely? This could be a bug in the AIGLX/XGL features in the nvidia driver.
Comment by Urs Wolfer (uwolfer) - Friday, 29 June 2007, 08:24 GMT
This is probably the same issue:
http://bugs.archlinux.org/task/7230
Comment by Greg Meyer (oggb4mp3) - Friday, 29 June 2007, 20:14 GMT
I have some more info for my second problem, the one where X causes the high CPU usage and appears frozen.

It has happened 2x in the past two days, both times after coming back from being away. When I sat down, the high cpu usage was going on and had been for awhile based on my cpu usage meter. I am using the xorg-server from testing btw, in fact, my whole box runs testing and is up to date.

The programs running when this occurred were different each time.

yesterday
KDE, Beryl running but not active, kwalett, superkaramba and kmix were active in the tray. open apps were Opera, Amarok, Skype, Kmail and vmware had a windowsXP session running.

Today
KDE, Beryl running but not active, kwalett, superkaramba and kmix were active in the tray. open apps were Opera, Firefox and Konqueror.

I am going to try now without kdm loaded, to see if that has anything to do with it, and perhaps I should try rolling back the xorg-server. I wish I could trigger this bug at will so it would be easier to test various combinations.

Also, my logs show nothing, and I tried to attach gdb to the session and get a backtrace, but it is useless because of the stripped binaries.
Comment by Greg Meyer (oggb4mp3) - Friday, 29 June 2007, 20:15 GMT
Why are my comments being posted 2x?
Comment by Greg Meyer (oggb4mp3) - Saturday, 30 June 2007, 03:24 GMT
Jan: I know Beryl was running both times, but I have tested this earlier by making sure KDE loaded without Beryl, and it still happened. I am trying to recreate again without Beryl running, and if it happens again, I will try to recreate in GNOME instead of KDE.
Comment by Greg Meyer (oggb4mp3) - Saturday, 30 June 2007, 19:39 GMT
It just happened to me again, without Beryl loaded, so I don't think it is Beryl, but I suppose it still could be the nvidia driver. I am going to try and recreate it in gnome, to rule out kde causing it, then I'll try out the nv driver.
Comment by Greg Meyer (oggb4mp3) - Sunday, 01 July 2007, 20:32 GMT
I am starting to wonder if this is related to KDE somehow. I have been running in gnome all day with just gtk apps and haven't had a problem. Perhaps I should recompile kdelibs against the sorg-server-1.3 in testing. I wonder if something like that could cause it, a KDE compiled against xorg-server-1.2 running on xorg-server-1.3.

I'll keep testing and report back.
Comment by Urs Wolfer (uwolfer) - Sunday, 01 July 2007, 20:35 GMT
I'm not 100% sure, but I think I have had such freezes also before xorg-server 1.3 was out...
Comment by Jan de Groot (JGC) - Sunday, 01 July 2007, 20:50 GMT
There's nothing that links KDE to an Xorg-server version.
Comment by Blaž Tomažič (billy) - Monday, 02 July 2007, 05:58 GMT
i'm using xfce and fglrx so i don't think this problem is related to KDE or nvidia drivers.
Comment by Greg Meyer (oggb4mp3) - Monday, 02 July 2007, 13:37 GMT
Interestingly though, I have been working in gnome for 2 days and have not experienced the problem once. 6 times I have left the machine logged in for extended periods of time, and each time I came back to it, it was fine. During the week prior, I would have sat down to an unusable system at least twice in that period. I am going to switch back to KDE and see what happens.
Comment by Alexander Baldeck (kth5) - Tuesday, 03 July 2007, 03:55 GMT
I have the exactly same problem only when I'm using the comercial nvidia driver. With xf86-video-nv the system is rock stable. By the way. crashes only happen on my laptop with has a 7400Go with turbo cache in it. All cards I've seen that come with only dedicated memory where fine.

Actually the kernek spits warnings when booting about not being able to claim some regions of memory, on my lappy while on the other stationary machine not.
Comment by Alexander Baldeck (kth5) - Tuesday, 03 July 2007, 09:26 GMT
I'm looking for infos about exact configurations for nvidia cards, from users who have lockups like me and also from those who don't.

* Ach32/Arch64
* kernel version
* xorg-server version
* full card name
* turbo cache / dedicated mem only
* special configs (like xinerama dualhead, twinvew etc)

No beryl please. That is to be considered unstable on all setups per se.

My Setup that locks up every now and then but works with xf86-video-nv:
* Arch64
* kernel: 2.6.22-rc5
* xorg-server 1.3.0.0 & 1.2.0
* nVidia Corporation GeForce Go 7400
* turbo cache (128M/512M)
* xinerama dualhead & single screen
Comment by Greg Meyer (oggb4mp3) - Tuesday, 03 July 2007, 13:16 GMT
Alexander: When you say lockup, you mean this 100% cpu thing or some other kind of freeze?

My specs are:
* Arch32
* Kernel 2.6.21.5-ARCH
* xorg-server 1.3
* nVidia GeForce 7300 GS
* Single Display

The specs for my video card say it has turbo cache. There is 256MB on board and it says it can use up to 512MB. This is the link to my card http://www.gigabyte-usa.com/Products/VGA/Products_Spec.aspx?ClassValue=VGA&ProductID=2376&ProductName=GV-NX73G256D-RH
Comment by Alexander Baldeck (kth5) - Tuesday, 03 July 2007, 18:08 GMT
By lockups I mean the complete freeze of the system making a hardware reset necessary.
Comment by Blaž Tomažič (billy) - Tuesday, 03 July 2007, 19:27 GMT
*Arch32
*kernel26 2.6.21.5-1 and kernel26suspend2 2.6.21.1-2
*xorg-server 1.3.0.0-1
*ati radeon mobility x1400 (fglrx 8.37.6-1)
*single display

most recently i had a lockup (where you can still move the mouse) at loading planeshift. i'll try to reproduce it again.
Comment by Greg Meyer (oggb4mp3) - Thursday, 05 July 2007, 05:09 GMT
I am starting to think that this might be related to the power management settings. Every time this has happened, my monitor has been in standby mode. I turned off the power control settings in kcontrol the past two days and it hasn't occurred once. As a regular KDE user, my logins to gnome were of a default install, and I believe the power control settings were off there too.

So anyway, when I re-enabled the power management in KDE, I have experenced ths lockup three times. I'll keep testing but i wanted to post this to see if it got any diagniostic juices flowing with anybody else watching this bug.
Comment by Alexander Baldeck (kth5) - Friday, 06 July 2007, 15:20 GMT
Downgrading to nvidia-96xx fixed my problems. Looks like 100.??.?? really is beta and even though I have a 7400go should use 96xx.
Comment by Satchmo (Satchmo) - Saturday, 07 July 2007, 12:26 GMT
I've also completely fixed the problem downgrading nvidia drivers. In my case it was _definitely_ a bug in nvidia 100.*
Comment by Greg Meyer (oggb4mp3) - Sunday, 08 July 2007, 02:35 GMT
I have decided to downgrade also because I need to be more stable. Before I did so though, I changed the power saving settings in kcontrol to disable suspend and use standbye only. After doing that, I did not have a recurrence of the problem for almost 36 hours. Not sure if this means anything, and if it is the driver it is probably an upstream problem.

BTW, I was using 100.14.09 because 100.14.11 was very unstable for me.
Comment by arnuld (arnuld) - Sunday, 08 July 2007, 03:51 GMT
i am using VESA driver from last 2 days now and i have experienced only 1 lockup. somebody advised me this on Arch Linux mailing list but videos play poorly with VESA driver when VIA is required by my hardware :-(
Comment by Jan de Groot (JGC) - Sunday, 08 July 2007, 09:27 GMT
For VIA you could try three different drivers, xf86-video-via, xf86-video-unichrome and openchrome. All of them share code, but they're maintained by 3 different maintainers, each with their own view on what hardware to support in what way.
Comment by arnuld (arnuld) - Sunday, 08 July 2007, 09:43 GMT
> For VIA you could try three different drivers, xf86-video-via, xf86-video-unichrome and openchrome.
> All of them share code, but they're maintained by 3 different maintainers, each with their own
> view on what hardware to support in what way.

hey JGC, thanks a lot buddy. i never knew that. xf86-video-unichrome cannot be used because my chipset(VT8237 on K8M800) is not supported: http://unichrome.sourceforge.net/

OpenChrome has my chipset but if i install it what "name" will i put in the "Driver" section of "/etc/X11/xorg.conf" ???
Comment by Jan de Groot (JGC) - Sunday, 08 July 2007, 10:40 GMT
OpenChrome installs as "via_drv.so", so you can leave it as "via" in your configuration file. I think unichrome uses the same. That's why they're drop-in replacements for eachother.
Comment by Greg Meyer (oggb4mp3) - Tuesday, 10 July 2007, 12:47 GMT
Well, I think I may have spoken too soon, as I woke up this morning to my machine doing the 100% cpu dance. I am running 2.6.22 and nvidia-96xx. Could this have naything to do with xorg-server 1.3? Is it safe to go back to 1.2?
Comment by arnuld (arnuld) - Tuesday, 10 July 2007, 16:41 GMT
> OpenChrome installs as "via_drv.so", so you can leave it as "via"
> in your configuration file. I think unichrome uses the same.
> That's why they're drop-in replacements for eachother.

ok, now i am using "openchrome" driver and from last 2 days no single X lockup or freeze :-), only "audacious" got a single but bad freeze and everything else is fine. i still want to keep a check for 1 full week so be ready for my next comment :0)

thanks a lot JGC
Comment by arnuld (arnuld) - Friday, 13 July 2007, 17:50 GMT
> ok, now i am using "openchrome" driver and from last 2 days no single X lockup or freeze :-),
> only "audacious" got a single but bad freeze and everything else is fine.
> i still want to keep a check for 1 full week so be ready for my next comment :0)

OK... still same lockups with same intensity and same in number :-( ... this shows that there is no problem with the driver. this hardware is total-crap. please do not buy this one.

need to buy new graphics card :(
Comment by arnuld (arnuld) - Friday, 13 July 2007, 17:52 GMT
> OK... still same lockups with same intensity and same in number :-( ...
> this shows that there is no problem with the driver. this hardware is total-crap.
> please do not buy this one.

> need to buy new graphics card :(


JGC, isn't there the possibility that there is bug in present Xorg ?
Comment by Alper Kanat (T-u-N-i-X) - Sunday, 15 July 2007, 23:36 GMT
I'm the author of "Unexpected Lockups in GNOME" thread and I also have the exact thing over here.. I'm using the 2.6.22-ARCH kernel and the nvidia-96xx series NVIDIA driver. I have HP NX 9105 laptop with GeForce4 MX 440 Go graphics card. I do have lockups when an application freezes and I try to close that application. Then, something happens and suddenly X stops responding to the keyboard input. I can move the mouse but can't type anything. I can't do things like CTRL-ALT-FX, CTRL-ALT-BACKSPACE, CTRL-ALT-DEL or any other combination. I've tried everything to get it working. Meanwhile everything works such as Conky and other applications. Firefox continue to download things, Conky continue to show its stats etc etc... So it's like some mysterious transparent wall between me and the applications that I can move the mouse but can't do anything else. I see it work but can't touch anything.. Besides, it would be a good idea to make some screensaver like this.. :)
Comment by Greg Meyer (oggb4mp3) - Thursday, 19 July 2007, 13:08 GMT
Continuing to try and debug this, I rolled back to the xorg-server 1.2.0-5 in currnet. If it was an X bug, I figured that it would go away. Alas it did not. I woke up this mornign to my cpu doing the alternating 100% thing and everything in the x session totally unresponsive. So no change at all.
Comment by sda (sda00) - Thursday, 19 July 2007, 22:54 GMT
I'm using Arch current + E16 + urxvt (no other WM's, DE's etc). No issues at all. But I installed nvidia 100* drivers from nvidia.com and "IgnorePkg = mesa nvidia-utils" is done. I'm using xmms, cause audacious indeed seems too cpu hungry and have some "fleas"...
Comment by Greg Meyer (oggb4mp3) - Friday, 20 July 2007, 22:31 GMT
Continuing to try and debug this, I rolled back to the xorg-server 1.2.0-5 in currnet. If it was an X bug, I figured that it would go away. Alas it did not. I woke up this mornign to my cpu doing the alternating 100% thing and everything in the x session totally unresponsive. So no change at all.
Comment by Billy Bob (necrolin) - Monday, 23 July 2007, 12:03 GMT
I had this same problem. Randomly X would lock up and I couldn't do anything. The keyboard would stop responding and nothing would work except the mouse.

Problem solved.

I removed the nvidia driver and compiled my own (0-9755). Now it's been working fine and not a single crash. So the problem seems to be a driver issue related to nvidia.
Comment by Billy Bob (necrolin) - Tuesday, 24 July 2007, 00:15 GMT
Update:

I've been using Gnome & Beryl extensively for 2 days with not a single crash or hard lock (it used to lock very often).

Now I'm noticing that every now and then windows such as: firefox, gnome-terminal, or Nautilus turn white and display no text or icons. If I minimize and maximize then everything is fine. Maybe this is the original issue that was crashing the Nvidia driver?? There's something wrong somewhere regardless, but at least no more hard locks. I hate having to press the reboot button, if you know what I mean. (After all instability is why I went from Win98 to Linux way back when in the year 2000, and it's one of the reasons why I've stayed with Linux. So this issue is very important.)
Comment by Greg Meyer (oggb4mp3) - Tuesday, 24 July 2007, 01:56 GMT
How do you explain that people with other video cards have reported this? People above have reported this with via and ati.

Also, i have rebuilt my nvidia module and it still happens.
Comment by Greg Meyer (oggb4mp3) - Tuesday, 24 July 2007, 02:19 GMT
Additional hints. ubuntu users experiencing same thing. They think they have narrowed it down to superkaramba, which I am in fact running. How about you other guys?


https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/51991
https://bugs.launchpad.net/ubuntu/+source/kdeutils/+bug/109507
Comment by Billy Bob (necrolin) - Tuesday, 24 July 2007, 04:33 GMT
I'm not running superkaramba, or anything else related to KDE for that matter. Also, I was using Ubuntu and never had it freeze in 2 years. However, the prebuilt drivers in Ubuntu did not work and produced a black screen. This I was able to fix by building the drivers myself.

How do I explain that other people with non-Nvidia cards are experiencing this? Easy, read my second comment. Now the windows turn white and all content disappears. This can be solved by minimizing and maximizing the affected window. So, obviously there is something else that's wrong, but at least the system doesn't hang (for me at least). It appears that this issue is related to the graphics driver and something else that is causing the crash.
Comment by arnuld (arnuld) - Tuesday, 24 July 2007, 04:42 GMT
> Comment by Bart Spyra (necrolin) - Tuesday, 24 July 2007, 09:33 GMT+5

> How do I explain that other people with non-Nvidia cards are experiencing this? Easy, read my
> second comment. Now the windows turn white and all content disappears. This can be solved by
> minimizing and maximizing the affected window.

well, your solution is for people using Desktops. you can not mimnimize/maximize a window in a Tiled Window Manager like stumpwm or ratpoison or wmii.

???
Comment by Billy Bob (necrolin) - Tuesday, 24 July 2007, 05:50 GMT
>well, your solution is for people using Desktops. you can not mimnimize/maximize a window in a Tiled Window Manager like stumpwm or ratpoison or wmii.

It's not really a solution, but it just happens to be what I'm doing and I'm only doing this because I don't know how to fix it. =S

Essentially what I'm saying is this:

1. The problem affects the driver but may not be directly caused by the video driver alone. Proof, it stopped on my computer when I compiled my own driver module. I'm using a little bit of an older driver so it may be that newer drivers may have made the issue worse?? I'm using 0-9755.

2. Even though the screen no longer freezes, windows now go all white and their contents disappears. This indicates that the problem still exists, it just no longer causes a hard crash on my particular system.

By the way, I don't think that it's related to superkaramba. Not only do I not use it now, but I did use it on Ubuntu and it did not crash on me.
Comment by sda (sda00) - Tuesday, 24 July 2007, 06:15 GMT
guys, here's some info:
[sda@black video]$ uptime
10:02:20 up 1 day, 9:06, 0 users, load average: 0.36, 0.38, 0.24

top - 10:02:39 up 1 day, 9:07, 0 users, load average: 0.26, 0.36, 0.23
Tasks: 72 total, 3 running, 68 sleeping, 1 stopped, 0 zombie
Cpu(s): 19.1%us, 7.6%sy, 0.0%ni, 71.9%id, 0.0%wa, 0.3%hi, 1.0%si, 0.0%st
Mem: 1035416k total, 1017000k used, 18416k free, 34508k buffers
Swap: 2104472k total, 0k used, 2104472k free, 576576k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
5676 root 15 0 153m 66m 6008 S 19.1 6.5 31:27.53 X

xrestop - Display: localhost:0
Monitoring 13 clients. XErrors: 0
Pixmaps: 61312K total, Other: 47K total, All: 61360K total

res-base Wins GCs Fnts Pxms Misc Pxm mem Other Total PID Identifier
1000000 12 25 1 16 89 39616K 3K 39620K 5717 urxvt
0600000 220 5 3 314 652 8363K 23K 8386K ? Enlightenment
0400000 0 2 0 2 8 5658K 240B 5659K ? <unknown>
0800000 27 38 1 215 64 3358K 4K 3362K 5707 gkrellm
1200000 36 26 2 37 10 2824K 3K 2828K ? XMMS - 414. Various - (65:51)
0a00000 108 1 0 107 4 870K 2K 873K ? E-Exec
1600000 186 42 1 142 100 571K 8K 580K 2577  FS#7513 : X freezes - SeaMonkey
0e00000 19 2 0 10 3 27K 576B 27K ? E-ScreenShoot
0c00000 13 1 0 5 4 20K 432B 21K ? Emix
1a00000 1 1 0 0 0 0B 48B 48B ? xrestop
1400000 1 1 0 0 0 0B 48B 48B ? <unknown>
1800000 1 0 0 0 0 0B 24B 24B ? <unknown>
0200000 0 1 0 0 0 0B 24B 24B ? <unknown>

no freezes, no issues ever. I do had some "fleas" with "audacious" - xmms rocks. nVidia drivers from nvidia.com - libglx.so.100.14.09
no frills, no hassle... composite extension is loaded...
may be removal of libdri.so from /usr/lib/xorg/modules/extensions/ (and /etc/X11/xorg.conf) could help?
Anyway, at least we've got a proven xorg-6.9.* as a last resort... But it seems to me that the matter of all the thrills could be in running apps instead of drivers/xorg itself...
Comment by Billy Bob (necrolin) - Tuesday, 24 July 2007, 10:18 GMT
> sda
>... But it seems to me that the matter of all the thrills could be in running apps instead of drivers/xorg itself...

Well, I have Arch installed on the same computer twice. One native and one in Vmware on WinXP. The Vmware version hasn't had any problems since I loaded it up a few weeks ago. The only real difference in the programs, between the two systems, is Beryl... and OpenOffice come to think of it. So I suppose we should ask ourselves are we all running Beryl?? Perhaps there is an incompatability between beryl and several graphics drivers?
Comment by arnuld (arnuld) - Tuesday, 24 July 2007, 11:19 GMT
> Comment by Bart Spyra (necrolin) - Tuesday, 24 July 2007, 15:18 GMT+5
> So I suppose we should ask ourselves are we all running Beryl?? Perhaps there is an incompatability
> between beryl and several graphics drivers?

NO, i am not running Beryl. i never ran Beryl. i used to use GNOME, then Xfce, then Windowmaker, then wmii and today stumpwm. BTW, i had the same lockups on Gentoo 2007.0 and i do not even have Nvidia card, i have VIA.

i must mention that replacing "xf86-video-via" with "openchrome" driver have reduced the number X lock-ups to 20-30%. this solution was suggested by "Jan de Groot (JGC)" here. may JGC live long :-)
Comment by Matt Runion (mrunion) - Tuesday, 24 July 2007, 18:46 GMT
At home running Beryl, nVidia 6560 GT, Gnome, Firefox as browser, latest released nVidia drivers (100.14.11), never any freezes.

On my Laptop (specs below) running Beryl (and tried compiz), nVidia 7400 Go, Gnome Firefox latest released nVidia drivers (100.14.11), freezes occur randomly. It seems I can make the frequency increase by rapidly scrolling down USING THE MOUSE WHEEL in Firefox WHILE a page is still loading alot of data/images. There's no guarantee that this will cause a freeze, but it does 50% of the time. the other time that a freeze isn't caused, the screen starts flickering on the bottom quarter of the screen pretty bad -- like it's having a hard time redrawing it. I'm using the Avant window navigator down there, so maybe that's a clue.

Oh, and whenever the problem arises, I get the following messages (or similar) in /var/log/everything.log:

Jul 23 08:24:26 plunkerbunkey NVRM: Xid (0001:00): 6, PE0000 0fc0 00dedfdf 000083c8 00000000 00fbf8f1
Jul 23 08:24:26 plunkerbunkey NVRM: Xid (0001:00): 30, L2 -> L1

Sometimes the "L2 -> L1" will say "L1 -> L0" or something. sometimes the "30" is a "28" or something. When the system "locks up" the mouse moves but nothing else works except a hard power-off. I've not let the machine sit for hours to test and see if it comes back. When it doesn't lock up but just "flickers", I just restart X and all is well.

I've tried using the Epiphany and Opera browsers and it doesn't fix the issue.

Laptop Spec:
HP DV8000 (actually it's a dv8230us -- specs on HP's site)
Centrino Duo (T2300)
2GB RAM
nVidia 7400 Go with 256MB RAM
Dual 80GB drives
Wireless
CD/DVD, etc.
Comment by Beran Ultimate (bh3) - Thursday, 26 July 2007, 10:31 GMT
I suffer from this problem also, I can reproduce by running screensaver setup, just opening screensaver dialog (from gnome menu) causes lockup (perhars while rendering screensaver preview?). I can move mouse cursor, but nothing else, I cannot switch to console or shutdown Xserver. I can do only hard reset. Oh and im running compiz.
Spec:
* Ach32
* kernel 2.6.22.1
* xorg-server 1.2.0-5
* nvidia geforce 7600GT 256MB
Comment by Matt Runion (mrunion) - Thursday, 26 July 2007, 13:35 GMT
I was reading nVidia's Forums and it was suggested to try a few things. I don't have the link to the thread in front of me or I'd post it. It IS a sticky in the Linux Drivers section (concerns Stability).

Anyway, I tried the "idle=poll" boot parameter. I booted up and TRIED to crash things by scrolling too fast, etc. I couldn't get the machine to lock up. But I only used it for about 30 minutes at that sitting. The lockup is so random that just 30 minutes hasn't proven anything. I'll keep trying that though and see if it helps.

But something is definitely going on. (Oh, I switched to compiz instead of beryl and still got a lockup -- though that was BEFORE the idle=poll.)

Comment by Billy Bob (necrolin) - Thursday, 26 July 2007, 23:01 GMT
This all seems so random. Many people are experiencing this problem with many kinds of video cards, many different kinds of desktops, etc. Several people have suggested that changing the drivers for their video card at least helped which makes me think that the problem resides in Xorg, or something else related to video.

All I know for sure is this:

a) It's been 4 days of heavy use and no more lockups. Solved by changing my video driver.
b) Screens going white and contents disappearing is related to Beryl, and more specifically the experimental add ons such as snow and tabs. I was able to reproduce this on Ubuntu by enabling these extra add-ons as well.
Comment by Matt Runion (mrunion) - Friday, 27 July 2007, 03:21 GMT
FYI -- using "idle=poll" as a boot option for th Kernel, I've still gotten no hard lockups, but I do still get flickering and the following error in the "everything" log when it happens:

Jul 26 23:11:46 plunkerbunkey NVRM: Xid (0001:00): 6, PE0000 0000 beef4901 000018bc 00000000 00000000
Jul 26 23:11:46 plunkerbunkey NVRM: Xid (0001:00): 30, L2 -> L1

To fix this I just restart X and the flicker clears. I don't KNOW that the idle=poll is "saving" me from what WOULD have been a lockup, but the "idle=poll" is not STOPPING the nVidia error being logged. I don;t know what this error means, though so I really can't check anything else right now.

My system specs are listed above:

DV8000 Laptop, Centrino Duo, nVidia 7400 Go 256MB RAM, etc. etc.

I hesitate to change to the "open" drivers because of my need for acceleration for GL apps (Blender, a game or two, etc.).
Comment by Matt Runion (mrunion) - Friday, 27 July 2007, 23:55 GMT
OK, here's something interesting....

I was hunting around nVidia's forums for more options and came across this:

http://www.nvnews.net/vbulletin/showthread.php?t=95090

That is a link to a message where someone has some code that they say locks up their machine. I compiled that code and ran it on a machine that has never locked up and on my laptop, which does lock up.

On the machine that never locks up -- the code ran fine and fast -- just spit out some lines and went fine. Nothing in the logs, no lockups, etc.

On my laptop -- which DOES lockup randomly -- I ran it and it STALLS at the line reading "glXMakeContextCurrent". What makes this even weirder is here is the "everything.log" dump of what happens when I run that program:

Jul 27 19:46:42 plunkerbunkey NVRM: Xid (0001:00): 13, 0003 beef3097 00004497 0000021c 00000000 00000002
Jul 27 19:46:46 plunkerbunkey NVRM: Xid (0001:00): 30, L0 -> L0
Jul 27 19:46:46 plunkerbunkey NVRM: Xid (0001:00): 9, Channel 00000020 Instance 00000000 Intr 00100000
Jul 27 19:46:46 plunkerbunkey ipw3945: Microcode SW error detected. Restarting.
Jul 27 19:46:46 plunkerbunkey ipw3945: request scan called when driver not ready.
Jul 27 19:46:46 plunkerbunkey NVRM: Xid (0001:00): 13, 0000 01016100 0000008a 0000057c 00ede9e3 00004000
Jul 27 19:46:46 plunkerbunkey NVRM: Xid (0001:00): 9, Channel 00000020 Instance 00000000 Intr 00100000
Jul 27 19:46:47 plunkerbunkey ipw3945: Error sending ADD_STA: time out after 500ms.
Jul 27 19:46:48 plunkerbunkey ipw3945: Can't stop Rx DMA.
Jul 27 19:46:48 plunkerbunkey ipw3945: Detected geography ABG (11 802.11bg channels, 13 802.11a channels)

Notice the 4-second delay in the logs when this started? That's the "stall" I mentioned above. The laptop screen flickered too! The blue, wireless "network" status light on my laptop (a DV8000) flickers when I run the program and then goes back to normal. Maybe this is related to why most of m lockups seem to occur when browsing/scrolling on the internet. To make it even "weirder", after I ran the program 4-5 times it eventually QUIT STALLING and no more messages got put in the logs! Does this give anyone any clues?



Comment by Greg Meyer (oggb4mp3) - Saturday, 28 July 2007, 02:55 GMT
He indicated that 9755 is fine. I noticed this started happening when I updated to 100.14.11 from 9755. I downgraded to nvidia-96xx, and it still occurs, I am going to try and use 9755 and see if that helps.

Also, following the lead in the ubuntu forums linked to above, I removed superkaramba, and three days have gone by with no problems. I suppose superkaramba could be using the offending commands, so it is still a driver issue, although this does not explain why people have reported this with hardware other than nvidia.
Comment by sinister99 (sinister99) - Monday, 30 July 2007, 03:44 GMT
I am the author of this same bug a couple months ago. Please see http://bugs.archlinux.org/task/7230 for more info on my troubleshooting, though it didn't fix anything.
Comment by Matt Runion (mrunion) - Monday, 30 July 2007, 17:18 GMT
Some more news:

I was scrolling down a large page, reading as I went. As I scrolled to the bottom (using Firefox and the mouse wheel), the PC locked up but the mouse still moved. I waited and after about a minute, it "unlocked". When it did so the bottom quarter of the screen would "flicker" about once every second or two. All this phenomena is mentioned through my earlier posts.

What I did this time, though is to run the sample code I mention in my most previous to this one. I ran it and it would stall a few seconds. Each time the wireless connection would reset (I'm using the ipw3945 drivers). After running it 4 times, it stopped stalling a few seconds, stopped resetting the wireless driver/card AND the screen flickering stopped.

Does this shed any information on the subject for anyone?
Comment by sinister99 (sinister99) - Monday, 30 July 2007, 22:32 GMT
My computer has only frozen when I'm not doing anything (if i leave it for a couple hours, or if i leave it on overnight). I'm not using any wireless or superkaramba.
Comment by Xavier (in-ferno) - Tuesday, 31 July 2007, 20:18 GMT
Same problem here, while playing VLC music files, or sometimes when eMule running..
I've got nvidia card & iwlwifi network wireless...
I'm fed up using a customized kernel (pacman -Syu break module for kernel: not same version)
Comment by Billy Bob (necrolin) - Monday, 06 August 2007, 08:26 GMT
I downloaded the latest drivers from NVidia (NVIDIA-Linux-x86-100.14.11) and the crashes started occurring again. So I returned back to NVIDIA-Linux-x86-1.0-9755 and everything is fine again. Not a single crash with the 9755 driver. It's pretty wacky, but Beryl and the new drivers do not get along on my system. This doesn't explain what happens on all the systems though.... erghhhh.

oggb4mp3 - Has installing the 9755 driver helped on your system?
Comment by Billy Bob (necrolin) - Monday, 06 August 2007, 08:27 GMT
I forgot to add that I did do a pacman -Syu and this problem does continue into "Don't panick".
Comment by Greg Meyer (oggb4mp3) - Monday, 06 August 2007, 12:16 GMT
I never reverted because it was going to take some work to track down the 9755 PKGBUILDs from cvs (the packages were no longer in my pacman cache), so I cannot confirm, but I did stop using superkaramba, and have not had a crash since. So I am convinced that the bug in the driver is triggered by some other app, in my case superkaramba, in others perhaps beryl.
Comment by Greg Meyer (oggb4mp3) - Wednesday, 08 August 2007, 14:26 GMT
Hello again. I just last night rolled back my nvidia driver to 9755 and turned superkaramba back on and woke this morning to see the cpus going crazy again. The interesting thing is, that until I click on something, everything looks normal. The mouse overs work, but as soon as I click once, everything becomes unresponsive.

So maybe my bug is in superkaramba after all, or maybe one of the themes I am using. I'll keep on it.
Comment by sinister99 (sinister99) - Wednesday, 08 August 2007, 20:34 GMT
Using the latest NVIDIA driver (in current), my computer no longer freezes when I turn off Superkaramba. The computer did freeze with the same driver while using Superkaramba. It also did using the 9755 driver with or without Superkaramba.
Comment by Billy Bob (necrolin) - Sunday, 12 August 2007, 21:58 GMT
Good news and bad news.

Bad: I Googled this issue and this is actually a pretty old problem that you can see lots of even way back in 2005. It seems to be either related to the kernel or Xorg, because it started happening when Xorg started being introduced in Linux. It seems that under certain HARDWARE and software conditions Linux just crashes.... =( So sad.

My GeForce 6200 was fine with the 9755 driver, but I decided to do a small upgrade to a GeForce 8500 which didn't work under that driver. This resulted in me having to use the newest drivers and splat, die, crash. I reinstalled Ubuntu and experienced the same thing. In frustration I looked up the problem in the Nvidia forums which brings me to the good news.

Good: 1. I'm back on Arch. 2. Good news for the people with NVidia cards and VIA chipsets. There are some incompatibilities there and there is a patch which works for me. The patch is EXPERIMENTAL, but is provided by NVIDIA. And again, for me it seems to fix the problem. I've been running Compiz-Fusion without any crashes for a few hours. I'll keep you posted.

Here's a link to the NVidia forums. Scroll down until you see the NVidia employee linking to the patch. There are some INSTRUCTIONS there. The Nvidia patch is here:

http://www.nvnews.net/vbulletin/showthread.php?t=87918&page=7&highlight=freezes

Hopefully it helps a few of you out.

Oh hell, I'll also copy and paste for the lazy people.... =) lol The patch is also attached.

Quote:

I found that the workaround referred to earlier is incomplete in 100.14.xx, supporting reports of a regression since 1.0-96xx; could those of you seeing problems with 100.14.11 try the attached (experimental) patch? It should improve stability with NV44 and G72 based graphics cards on certain ATi chipsets.

To apply the patch, use:

# sh /path/to/NVIDIA-Linux-x86-100.14.11-pkg0.run --apply-patch /path/to/NVIDIA_kernel-100.14.11-336672.diff.txt
# sh NVIDIA-Linux-x86-100.14.11-pkg0-custom.run

Comment by sinister99 (sinister99) - Monday, 13 August 2007, 03:13 GMT
I tried the patch, but unfortunately it didn't work. It froze rather quickly actually.....
Comment by Billy Bob (necrolin) - Monday, 13 August 2007, 09:10 GMT
>> Comment by Max Nemeth (sinister99) - Monday, 13 August 2007, 03:13 GMT
>> I tried the patch, but unfortunately it didn't work. It froze rather quickly actually.....

Remember that this fix is only for people with motherboards that have ATI chipsets AND who also nave certain NVIDIA graphics card. I'm sorry that this didn't work for you though.

This problem has been around for 2 years, so I don't think that any 1 patch will help everyone unless it's a proper Xorg or Kernel patch. On the other hand this has helped some a few people, as you'll see if you read the forum.

For those that meet the above criteria try out the patch. It's been about a day for me and I'm solid, although I've noticed a small performance hit with Compiz-fusion.
Comment by Billy Bob (necrolin) - Wednesday, 15 August 2007, 04:10 GMT
Update. There have been no more lockups on my system even with pretty heavy use from Sunday to Wednesday. This patch fixed the issue for me.
Comment by Dimos Dimoulis (dimosd) - Tuesday, 28 August 2007, 13:25 GMT
Nvidia users: try downgrading "nvidia" and "nvidia-utils" from 100.14.11 to 100.14.09 (use ABS)

More info:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=434900
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=435100
http://www.nvidia.com/object/linux_display_archive.html

Apparently worked for this 8600 GTS (running compiz-fusion). Please report back if it worked for you.
Comment by sinister99 (sinister99) - Friday, 07 September 2007, 11:50 GMT
I tried downgrading to 100.14.09 as suggested above, and it still froze (superkaramba).

6600GT
Comment by Dimos Dimoulis (dimosd) - Saturday, 08 September 2007, 10:48 GMT
Are you getting the same freezes with "nv"? (it was safe for me)
Comment by sinister99 (sinister99) - Saturday, 08 September 2007, 12:16 GMT
Trying it now...will let you know in however long it takes to freeze or not freeze.
Comment by sinister99 (sinister99) - Sunday, 09 September 2007, 17:43 GMT
It froze using the nv driver (Superkaramba).
Comment by Evgeny Grablyk (SilentMan) - Tuesday, 25 September 2007, 11:32 GMT
Same. What I only can do is move mouse pointer and press Alt + Ctrl + Backspace, which restarts my X server and computer works fine then. Tried using nv driver instead of nvidia, but problem left.
Comment by Evgeny Grablyk (SilentMan) - Thursday, 27 September 2007, 13:05 GMT
For now it freezes only when some apps are launched/shut down. For example when GIMP launches, or launched with wine Half-Life 1 is shut down.
Comment by Evgeny Grablyk (SilentMan) - Thursday, 27 September 2007, 15:02 GMT
For now it freezes only when some apps are launched/shut down. For example when GIMP launches, or launched with wine Half-Life 1 is shut down.
Comment by Billy Bob (necrolin) - Friday, 28 September 2007, 02:09 GMT
When my computer used to freeze up I couldn't restart the X server because the keyboard would stop functioning. To me it looks like there are a few separate and distinct problems on this page. The problems all lock up X so they've been lumped together as one problem.
Comment by sinister99 (sinister99) - Friday, 28 September 2007, 18:35 GMT
I made 3 changes to my system, and now it hasn't crashed in 3 days...YET

Turned on a screensaver (through the kde control panel)
updated xorg to 7.3 (testing repo)
updated nvidia driver to x.19 (testing repo)

I'll be gone for a week, so I can't really test it for longer until I get back, but I will post if it crashes on me....
Comment by Dimos Dimoulis (dimosd) - Sunday, 30 September 2007, 15:46 GMT
From nvidia 100.14.19 changelog
-Fixed stability problems with some GeForce 8 GPUs

So it may be the solution to -some- of the stability problems reported here
Comment by Jason Chu (jason) - Monday, 01 October 2007, 14:10 GMT
I have also had the everything freezes except mouse movement problem.

* Ach32
* 2.6.22.9
* 1.4-3 (and 1.4-1)
* Intel i945GM
* xfce4, no composite, no beryl, no compiz
* happens only when I'm at the computer, never when the computer is sitting by itself
Comment by Corrado Primier (bardo) - Friday, 05 October 2007, 10:35 GMT
Same as Jason Chu, but I have a Radeon X1300. It seems that the latest xfwm4 patch in testing fixes the problem, but I'll need a few more testing to be sure. I'll write an update this evening.
Comment by Johannes Svensson (Abadaar) - Sunday, 07 October 2007, 14:54 GMT
I had this problem before that when I was using Firefox or epiphany (probably and gecko browser) the computer would freeze up when I was scrolling fast. Everything, including the mouse, locked up and I had to do a hard reboot. I have not experienced this sort of crash in the latest weeks so it seems it might be solved (or I changed something). This might not be an xorg bug, it might just be an gecko/kernel bug.

* Arch32
* 2.6.22.9-1
* xorg-server 1.2.0-5
* GeForce 7800GTX, nvidia 100.14.11-4
* xfce4, composite on, no beryl or compiz
* Happened only while scrolling in Firefox.
Comment by Corrado Primier (bardo) - Monday, 08 October 2007, 11:43 GMT
I decided to bring on the testing for a few days. Everything works well and I didn't get any lockup, though I still experience a strange graphical glitch that didn't occur before the Xorg update that broke everything in testing.

When I close a graphical session cleanly, with the Xfce4 logout, my console text is light blue, and all the other colors seem to be "shifted" in the same direction. If I log in and then out again the same happens, but light blue becomes dark blue. After the third time everything is black, but still works. If I don't exit cleanly, and just kill X with Ctrl-Alt-Backspace instead, colors are fine. Killing X also has the power to "heal" the console colors and turn them white again (seems like a bad RPG o.O ).

This last problem, anyway, seems like an unrelated bug that appeared in the same release.
Comment by Shahar (sweiss) - Thursday, 11 October 2007, 21:50 GMT
I'm also having the issue of X using up 100% CPU after being idle.
However, I believe I have worked around it, the solution being turning DPMS off.

Just add the following to your .xinitrc or similar:

exec xset -dpms


I've already kept the machine running for 24 hours, during the night - no freeze when I wake up. I will try leaving it on again today to see what happens.

Hope this helps.
Comment by sinister99 (sinister99) - Friday, 12 October 2007, 20:07 GMT
I haven't had any crashes since I turned on a screensaver, it seems if the screen is changing, it doesn't freeze up.

However, X started freezing for me when opening mplayer (or one of the mplayer frontends) fairly frequently...
Comment by Shahar (sweiss) - Monday, 15 October 2007, 11:39 GMT
I'm afraid my suggested solution regarding turning DPMS off failed me today, as I had reached the same 100% cpu thing.

What a shame.
Comment by Dimos Dimoulis (dimosd) - Sunday, 21 October 2007, 21:03 GMT
Like others noted, this bug report involves various distinct causes and symptomps.
In my case the instability of Nvidia 8600GTS (and other Geforce 8 GPUs) was solved by upgrading to nvidia and nvidia-utils 100.14.19 - 100.14.x before this was unstable.
Comment by Roman Kyrylych (Romashka) - Monday, 22 October 2007, 12:58 GMT
Hmm, now I've installed Arch on my new machine and X freezes for ~1-2 seconds every ~20-30 minutes, but only when playing video with totem and compiz enabled.
Also I cannot switch to plain text console during freeze.
I use nvidia with Testing disabled.
Comment by arnuld (arnuld) - Monday, 22 October 2007, 15:56 GMT
I have installed the latest "Don't Panic" release: Archlinux-x86_64-2007.08-2.core.iso for my AMD64 Athlon. I am using "openchrome" rather than "xf86-video-via" driver. From last 10 days, I did not even get a single freeze. It is working fine now. If I ever get single freeze, I will report here with as much information as possible.

Comment by Alessio Bolognino (mOLOk) - Sunday, 04 November 2007, 18:06 GMT
Sometimes X freezes on switch to console / exit.
I'm using xf86-video-intel, 945GM card (MacBook Core 2 Duo).
Never happened with old intel driver (xf86-video-i810).

Loading...