Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75132 - [go-tools] Invalid package version causing inability to use pacman to download

Attached to Project: Community Packages
Opened by Jake Brennan (jbrennan2624) - Tuesday, 21 June 2022, 20:25 GMT
Last edited by Morten Linderud (Foxboron) - Friday, 24 June 2022, 07:36 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To Morten Linderud (Foxboron)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: The filename for the archived package uses a space, causing a failure to download from mirrors. Downloading the file directly from archlinux.org reveals the issue: The filename is as follows:
"go-tools-4 0.1.11-1-x86_64.pkg.tar.zst"

Additional info:
* package version: 4:0.1.11-1

Steps to reproduce:
# pacman -S go-tools
"warning: failed to retrieve some files"
"error: failed to commit transaction (failed to retrieve some files)"
"Errors occurred, no packages were upgraded."
This task depends upon

Closed by  Morten Linderud (Foxboron)
Friday, 24 June 2022, 07:36 GMT
Reason for closing:  Works for me
Comment by Morten Linderud (Foxboron) - Tuesday, 21 June 2022, 21:01 GMT
There is no space there. It should be ':' and we do not mangle epochs. Are you sure this is an actual bug and not a misbehaving mirror/browser/something else?

Can you point out the mirror serving this with a space?

Loading...