Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#75100 - [request] Firmware package for sof-audio-pci-intel-tgl module

Attached to Project: Arch Linux
Opened by Tom (reztho) - Friday, 17 June 2022, 16:10 GMT
Last edited by Antonio Rojas (arojas) - Friday, 17 June 2022, 16:21 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
It looks like recent Intel sound cards requires of firmware not available in the core repository. Could it be possible to have a firmware-XXXX package for this one? https://github.com/thesofproject/sof-bin/

kern :warn : [ +0.000331] sof-audio-pci-intel-tgl 0000:00:1f.3: Direct firmware load for intel/sof/sof-adl.ri failed with error -2
kern :err : [ +0.000002] sof-audio-pci-intel-tgl 0000:00:1f.3: error: sof firmware file is missing, you might need to
kern :err : [ +0.000001] sof-audio-pci-intel-tgl 0000:00:1f.3: download it from https://github.com/thesofproject/sof-bin/
kern :err : [ +0.000001] sof-audio-pci-intel-tgl 0000:00:1f.3: error: failed to load DSP firmware -2
kern :err : [ +0.229374] sof-audio-pci-intel-tgl 0000:00:1f.3: error: sof_probe_work failed err: -2

Thanks and best regards.
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 17 June 2022, 16:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  https://archlinux.org/packages/extra/x86 _64/sof-firmware/

Loading...