Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#75092 - strip fails for .o objects if debug is enabled

Attached to Project: Pacman
Opened by freswa (frederik) - Thursday, 16 June 2022, 18:15 GMT
Last edited by Allan McRae (Allan) - Sunday, 09 October 2022, 01:18 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version 6.0.1
Due in Version 6.1.0
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Summary and Info:
As reported here [0], '.o' objects aren't stripped correctly, since they fall through our for loop in strip.sh.

Steps to Reproduce:
Build glibc, python2 or python and check the build object files for a correct strip via `file <objectfile>.

[0] https://bugs.archlinux.org/task/74941
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 09 October 2022, 01:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  git commit de11824527ec4e2561e161ac40a5714ec943543c

Loading...