Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7507 - udev fails: makepkg -L fails due to the logging

Attached to Project: Arch Linux
Opened by Andreas Radke (AndyRTR) - Sunday, 24 June 2007, 13:24 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 24 June 2007, 17:32 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version 3.0.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

makepkg -L fails while makepkg works

Steps to Reproduce:

try to build new udev-113-1

with -L it fails:

make[1]: Leaving directory `/var/abs/base/udev/src/udev-113/extras/path_id'
make[1]: Entering directory `/var/abs/base/udev/src/udev-113/extras/rule_generator'
Please create a man page for this tool.
make[1]: Leaving directory `/var/abs/base/udev/src/udev-113/extras/rule_generator'
install: omitting directory `extras/path_id'
==> ERROR: Build Failed. Aborting...

while it builds fine when not logging the build.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 24 June 2007, 17:32 GMT
Reason for closing:  Fixed
Comment by Andrew Fyfe (space-m0nkey) - Sunday, 24 June 2007, 16:23 GMT
The problem is 'install -D -m755 extras/path_id $startdir/pkg/sbin/path_id' it should be 'install -D -m755 extras/path_id/path_id $startdir/pkg/sbin/path_id'

The problem is actually with makepkg without logging for some reason it's not aborting the build when the install command fails.
Comment by Andreas Radke (AndyRTR) - Sunday, 24 June 2007, 17:10 GMT
ok, then this should be a packaing issue. will assign it to the udev maintainer now and rename the topic.

Loading...