FS#74978 - [python-internetarchive] drop depending on [python-args], [python-six]

Attached to Project: Community Packages
Opened by Marcell Meszaros (MarsSeed) - Monday, 06 June 2022, 23:16 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 02 September 2023, 17:23 GMT
Task Type Support Request
Category Packages
Status Closed
Assigned To Florian Pritz (bluewind)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description: It seems [python-internetarchive] does not need:

- the deprecated [python-args]
(uses 'python-docopt' instead)

- the old-Python-compatibility module [python-six]
(it requires Python 3.7+, dropped compatibility with 3.0-3.6)

In addition to the references below as evidence, I've succesfully
built and ran this Python based CLI application without the two
mentioned unneeded dependencies.


* package version(s):
- [python-internetarchive] 3.0.0 [community], 3.0.1 (latest version)

* Python requirements ( Python >= 3.7 ):
- https://pypi.org/project/internetarchive/

* Python module requirements:
- https://github.com/jjjake/internetarchive/blob/v3.0.1/setup.cfg#L31
- https://github.com/jjjake/internetarchive/blob/v3.0.1/pex-requirements.txt
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 02 September 2023, 17:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-internetarchive 3.5.0-1