Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74915 - [metasploit] ctrl+z backgrounds msfconsole instead of the session

Attached to Project: Community Packages
Opened by hivenznevih (hivenznevih) - Tuesday, 31 May 2022, 03:20 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 16 June 2022, 06:59 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Hi, it seems that there is a bug in msfconsole starting script. When in reverse shell, it is not possible to use CTRL+Z to send the session in the background. Instead, msfconsole is sent to the background.
This has already been fixed in Kali/Metasploit but not yet in BlackArch/Arch.

Additional info:
* package version(s): 6.1.35-1
* link to upstream bug report, if any:
https://github.com/rapid7/metasploit-framework/issues/8860
https://bugs.kali.org/view.php?id=7646
https://github.com/BlackArch/blackarch/issues/3438

Steps to reproduce:
Described here by another reporter: https://bugs.kali.org/view.php?id=7646

Thanks!
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 16 June 2022, 06:59 GMT
Reason for closing:  Fixed
Comment by Alexandre ZANNI (noraj) - Tuesday, 31 May 2022, 12:26 GMT Comment by Levente Polyak (anthraxx) - Tuesday, 31 May 2022, 20:58 GMT
Please test 6.2.0-1
Comment by Levente Polyak (anthraxx) - Tuesday, 31 May 2022, 20:58 GMT
Please test 6.2.0-1
Comment by Alexandre ZANNI (noraj) - Wednesday, 01 June 2022, 17:00 GMT
I tested 6.2.0, for me msfconsole is fixed, i didn't test with msfdb but since the exec was applied everywhere it should be good.
Comment by hivenznevih (hivenznevih) - Wednesday, 15 June 2022, 15:41 GMT
Tested with 6.2.0-2 and it works, thanks.

Loading...