Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74896 - booting dracut initramfs leads to lack of wifi device node

Attached to Project: Arch Linux
Opened by Moo-Crumpus (Moo-Crumpus) - Sunday, 29 May 2022, 10:33 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 19 June 2022, 09:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I use two PCs with Archlinux. Both have Intel wireless cards that use the iwlwifi kernel module.

My problem is that when I use an initramfs created with dracut, no device nodes are created for the wireless cards, only for Ethernet. If I switch back to mkinitcpio everything works.

Does dracut have an issue with Intel wireless cards? I don't run any individual dracut config.


Additional info:
* package version(s)
dracut 056-1

* config and/or log files etc.
default

* link to upstream bug report, if any

Steps to reproduce:
just run dracut and create initramfs, reboot
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 19 June 2022, 09:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See comment
Comment by loqs (loqs) - Monday, 13 June 2022, 16:57 GMT
https://bbs.archlinux.org/viewtopic.php?pid=2041009#p2041009
"Back from vacancies, both computers demand a hundred of packages updated and things go so well. The tings work, allthough the issue itself is not solved in a way I know what was going on. Nevertheless, solved."

Loading...