Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74871 - [coreutils] version 9.1-1 has broken cp -ax

Attached to Project: Arch Linux
Opened by Ioannis Kozanitis (giannis-arch) - Friday, 27 May 2022, 17:27 GMT
Last edited by Toolybird (Toolybird) - Friday, 29 July 2022, 06:15 GMT
Task Type Bug Report
Category Packages: Core
Status Assigned
Assigned To S├ębastien Luttringer (seblu)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

The "cp" command, does not work any more, when it is used with -ax parameters

Additional info:
* coreutils 9.1-1
* Error message: It can not find folder
*

Steps to reproduce:
Install the archiso to the new root with to copy everything in the live environment to the new root.
Using the command cp -ax / /mnt
The error message is "it can not find folder" and then it mirrors itself, /mnt in /mnt ....
As a temporary solution, i tried to downgrade to coreutils version 9.0-2 and the problem solved...
This task depends upon

Comment by Toolybird (Toolybird) - Friday, 29 July 2022, 06:15 GMT Comment by Ioannis Kozanitis (giannis-arch) - Friday, 29 July 2022, 10:30 GMT
This patch works perfectly. The package built without errors and the command "cp -ax / /mnt" works normally.

Loading...