Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7487 - audacious-player plalylist contain ?xspf

Attached to Project: Arch Linux
Opened by Peter Avramucz (muczyjoe) - Thursday, 21 June 2007, 11:43 GMT
Last edited by Travis Willard (Cerebral) - Tuesday, 03 July 2007, 13:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Travis Willard (Cerebral)
Architecture i686
Severity Low
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

If i start, and add some files, it's ok, but after restart tha items contain ?xspf at the end. An audacious dev said, i should compile it by and it worked. He said, it's because the cflags, but i've compiled with the PKGBUILD, and it works.
So the solution might be so simple, as repackaging the audacious-player.
This task depends upon

Closed by  Travis Willard (Cerebral)
Tuesday, 03 July 2007, 13:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  AHA! I've finally figured out what the problem is, for reals. I'm uploading fresh -player and -plugins packages that hopefully should put an end to this confusing and annoying bug.

Basically, the player and plugins pkgs must always be built with the same compile-time flags (and probably the same minor version of GCC too) - if they're not, then oddness happens with the playlist. What happened in this case is that we were using a version of the player released a while ago. Then, GCC was updated and -mtune=generic was made default. Then, without releasing a new player, audacious released a new version of the plugins. So, the plugins were built with the new GCC and new flags, while the player was still built with the old flags. That's why removing -mtune=generic from the plugins seemed to help.

Anyway, I've rebuilt both player and plugins with proper cflags. Versions are audacious-plugins 1.3.5-5, audacious-player 1.3.2-4.
Comment by Travis Willard (Cerebral) - Thursday, 21 June 2007, 12:47 GMT
  • Field changed: Percent Complete (0% → 10%)
I'll take a look - did he happen to mention which cflags might be causing the problem?
Comment by Peter Avramucz (muczyjoe) - Thursday, 21 June 2007, 13:04 GMT
He thinks, that -mtune=generic causes the problem.
Comment by Travis Willard (Cerebral) - Friday, 22 June 2007, 01:19 GMT
I really doubt this would be caused by a compiler optimization, but for the sake of completion I compiled without any of our default flags - then the playlist wouldn't save at all. I removed each flag, one at a time, and it didn't help. Looks like it's some deeper bug.

http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/6a9bfc9c5ade7d0c/99ec4e414a3fd5fa

Happens on debian too.
Comment by Travis Willard (Cerebral) - Friday, 22 June 2007, 01:36 GMT
Ugh - okay, just on a whim I tried to compile the audacious-plugins package, not the -player, without -mtune and now it worked. I'll upload a new version of the plugins momentarily.
Comment by Roman Kyrylych (Romashka) - Thursday, 28 June 2007, 08:29 GMT
re-opened on this request: The bug still exists with audacious-player 1.3.2-2 and audacious-plugins 1.3.5-4.
Comment by Travis Willard (Cerebral) - Thursday, 28 June 2007, 12:20 GMT
BAh, you're right - I haven't been using any audio player lately so I didn't notice, but it's wierd that it worked for a while after I recompiled the plugins.

I'm stumped - no matter how I rebuild it, it keeps coming up..

Ooo! Nevermind - I just tried after removing ALL cflags and it seems to be working for me now. I'll test it for the next couple of days to make sure it's not another red herring, then I'll re-upload.
Comment by Peter Avramucz (muczyjoe) - Thursday, 28 June 2007, 12:35 GMT
cd /var/abs/extra/multimedia/audacious-plugins
makepkg
pacman -U audacious-plugins-1.3.5-3-i686.pkg.tar.gz

This works for me. However the package from arch mirrors, doesn't... :-/
Comment by Travis Willard (Cerebral) - Thursday, 28 June 2007, 12:43 GMT
Peter - what're your cflags in /etc/makepkg.conf? What's your version of gcc?
Comment by Peter Avramucz (muczyjoe) - Thursday, 28 June 2007, 14:15 GMT
CFLAGS="-march=i686 -mtune=generic -O2 -pipe"
CXXFLAGS="-march=i686 -mtune=generic -O2 -pipe"

local/gcc 4.2.0-2

Everything default.
Comment by Travis Willard (Cerebral) - Monday, 02 July 2007, 19:50 GMT
New versions should hopefully fix this. I'm leaving this FS open though, just in case.
Comment by Bjoern Hiller (Zaphod) - Tuesday, 03 July 2007, 10:20 GMT
The new version doesn't save any playlist at all. A file is created, but with no usefull content (only the body is present). Furthermore, there is no difference between saving the default playlist to ~/.config/audacious/playlist.xspf while terminating audacious or save it to another location.

Loading...