Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74853 - [jenkins] Fail to start with service (jdk 8 leftover in config)

Attached to Project: Community Packages
Opened by Ewen (ewen_bara) - Wednesday, 25 May 2022, 19:05 GMT
Last edited by Felix Yan (felixonmars) - Saturday, 28 January 2023, 09:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Filipe Laíns (FFY00)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: Jenkins does not start, the service try to use old java version


Additional info:
* package version(s): 2.348-2
* config and/or log files etc.:
** May 25 20:05:13 systemd[1]: Starting Extendable continuous integration server...
** May 25 20:05:13 systemd[1]: Started Extendable continuous integration server.
** May 25 20:05:13 jenkins[3400]: /bin/sh: line 1: /usr/lib/jvm/java-8-openjdk/jre/bin/java: No such file or directory
** May 25 20:05:13 systemd[1]: jenkins.service: Main process exited, code=exited, status=127/n/a
** May 25 20:05:13 systemd[1]: jenkins.service: Failed with result 'exit-code'.

Steps to reproduce: Install or update jenkins with package version 2.348-2 and run "systemctl start jenkins.service"

In attachment a patch file to fix the issue. Can be apply with "patch -p1 /etc/conf.d/jenkins jenkins.conf.patch"
This task depends upon

Closed by  Felix Yan (felixonmars)
Saturday, 28 January 2023, 09:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.388-2
Comment by Ewen (ewen_bara) - Friday, 15 July 2022, 20:51 GMT
  • Field changed: Percent Complete (100% → 0%)
Hello,

The  FS#71111  is for update jenkins' dependency to java 11.
The task is about post update issue.
Comment by Toolybird (Toolybird) - Friday, 15 July 2022, 20:58 GMT
Sorry about that.. There is another task re the conf issue ( FS#75273 ). Seeing as yours was filed first and includes a patch, I'll close the other one as a dupe.
Comment by Toolybird (Toolybird) - Friday, 16 December 2022, 20:43 GMT
Dupe  FS#76846 

Loading...