Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74844 - [valgrind] Fatal error at startup: a function redirection which is mandatory for this platform-tool

Attached to Project: Arch Linux
Opened by shenlebantongying (shenlebantongying) - Tuesday, 24 May 2022, 14:28 GMT
Last edited by Toolybird (Toolybird) - Friday, 29 July 2022, 03:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The valgrind doesn't work, it seems to lack something which i cannot be sure.

Steps to reproduce:

> valgrind ./a_binary
==162419== Memcheck, a memory error detector
==162419== Copyright (C) 2002-2022, and GNU GPL'd, by Julian Seward et al.
==162419== Using Valgrind-3.19.0 and LibVEX; rerun with -h for copyright info
==162419== Command: ./a_binary
==162419==

valgrind: Fatal error at startup: a function redirection
valgrind: which is mandatory for this platform-tool combination
valgrind: cannot be set up. Details of the redirection are:
valgrind:
valgrind: A must-be-redirected function
valgrind: whose name matches the pattern: strlen
valgrind: in an object with soname matching: ld-linux-x86-64.so.2
valgrind: was not found whilst processing
valgrind: symbols from the object with soname: ld-linux-x86-64.so.2
valgrind:
valgrind: Possible fixes: (1, short term): install glibc's debuginfo
valgrind: package on this machine. (2, longer term): ask the packagers
valgrind: for your Linux distribution to please in future ship a non-
valgrind: stripped ld.so (or whatever the dynamic linker .so is called)
valgrind: that exports the above-named function using the standard
valgrind: calling conventions for this platform. The package you need
valgrind: to install for fix (1) is called
valgrind:
valgrind: On Debian, Ubuntu: libc6-dbg
valgrind: On SuSE, openSuSE, Fedora, RHEL: glibc-debuginfo
valgrind:
valgrind: Note that if you are debugging a 32 bit process on a
valgrind: 64 bit system, you will need a corresponding 32 bit debuginfo
valgrind: package (e.g. libc6-dbg:i386).
valgrind:
valgrind: Cannot continue -- exiting now. Sorry.

This task depends upon

Closed by  Toolybird (Toolybird)
Friday, 29 July 2022, 03:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  valgrind 3.19.0-3
Comment by loqs (loqs) - Tuesday, 24 May 2022, 19:08 GMT Comment by shenlebantongying (shenlebantongying) - Wednesday, 25 May 2022, 03:13 GMT
Hi, I tried the method in the post, and it works for me. Thanks!

However, I still consider it is a bug rather than my misconfiguration, but I am probably wrong.
Comment by shenlebantongying (shenlebantongying) - Friday, 27 May 2022, 02:48 GMT
Hi, my problem is that I switched default shell to fish, and thus didn't include the /etc/profile.d/debuginfod.sh

Switching back to bash as default solved the problem.

Feel free to close this bug report.
Comment by Chih-Hsuan Yen (yan12125) - Saturday, 28 May 2022, 04:58 GMT
Yeah currently there are only bash and zsh startup scripts. In my opinion it's better to have at least some notes upon package installation via post_install().
Comment by Toolybird (Toolybird) - Friday, 29 July 2022, 03:13 GMT
> In my opinion it's better to have at least some notes upon package installation via post_install().

Sounds like a feature request? Wanna create a separate ticket?

Loading...