Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74843 - [reuse] missed dependency

Attached to Project: Community Packages
Opened by k4leg (k4leg) - Tuesday, 24 May 2022, 12:40 GMT
Last edited by George Rawlinson (rawlinsong) - Sunday, 19 June 2022, 19:06 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To George Rawlinson (rawlinsong)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

REUSE doesn't work without `python-setuptools` because REUSE requires `pkg_resources` module. See <https://github.com/fsfe/reuse-tool/blob/v1.0.0/src/reuse/__init__.py#L15>.

To reproduce:

1. Install `reuse` package.
2. Remove `python-setuptools` package (which is not in dependency graph for `reuse` package---see `pactree reuse` command output).
3. Run `reuse` command.
This task depends upon

Closed by  George Rawlinson (rawlinsong)
Sunday, 19 June 2022, 19:06 GMT
Reason for closing:  Fixed
Comment by George Rawlinson (rawlinsong) - Sunday, 19 June 2022, 19:04 GMT
Well, that's unfortunate! pkg_resources *really* should be a separate library. Thanks for the report, I'll add setuptools to dependencies shortly. :)

Loading...