Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74834 - [gimp-plugin-gmic] Blend [seamless] filter stopped working

Attached to Project: Community Packages
Opened by Sandro Manger (kbear) - Monday, 23 May 2022, 13:34 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 25 May 2022, 18:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Since the latest update (3.1.2-1) the gmic filter "Blend [Seamless]" stopped working. Selecting the filter from in the gmic UI filter list shows the following error message in the preview panel (numbers vary depending on image size):

*** Error in ./fx_blend_seamless_preview/fx_blend_seamless/*if/(...)/*local/ilaplacian/*if/*foreach/ ***
Command 'fft': gmicList<float32>::FFT(): Specified real and imaginary parts (1200, 875, 1, 4) have none 2^N dimension along the Y-axis.

Applying the filter using "OK" or "Apply" buttons results a popup window with the same error.

Additional info:
Package versions:
gimp 2.10.30-3
gimp-plugin-gmic 3.1.2-1
fftw 3.3.10-2

Steps to reproduce:

1) Create new image of any size.
2) Create a second layer or simply duplicate the default background layer.
3) Start the G'MIC plugin from the "Filters" menu.
4) Select filter "Blend [Seamless]" (use search or look in "Layers" submenu).
5) Set "Input Layers" dropdown menu to "All visible" (should be selected by default)
6) Error message appears in the preview and window.
7) Clicking "OK" or "Apply" results in the same error but in a popup window.
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 25 May 2022, 18:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  gmic 3.1.2-2
Comment by Jack Gargasz (plague) - Wednesday, 25 May 2022, 10:53 GMT
It looks like the package has not been compiled with FFWT3 for some reason.
Please note:
https://github.com/dtschump/gmic/issues/378
and
https://github.com/dtschump/gmic/issues/384

Loading...