Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74807 - [tlp] remove acpi_call from optdepends?

Attached to Project: Community Packages
Opened by mearon (mearon) - Friday, 20 May 2022, 14:30 GMT
Task Type Bug Report
Category Packages
Status Unconfirmed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

From the official docs: https://linrunner.de/tlp/installation/arch.html

> Arch Linux includes Linux kernel 5.17 (at the time of writing). In combination with TLP 1.5 it offers full battery care support (i.e. charge thresholds and recalibration) for ThinkPads from model year 2011 onwards. Therefore no external kernel modules are required with kernel 5.17 or newer and you do not need to proceed any further here.

I think acpi_call can be removed from optdepends then?

I also edited the wiki page to reflect this change: https://wiki.archlinux.org/title/Tlp#ThinkPads_only

It would be probably also helpful to change the description of the optional dependency tp_smapi from "ThinkPad battery functions" to "Battery functions for Thinkpads before SandyBridge" or similar.
This task depends upon

Comment by Doug Newgard (Scimmia) - Friday, 20 May 2022, 14:40 GMT
Arch also ships 5.15 as linux-lts. As well as numerous kernels in the AUR.
Comment by mearon (mearon) - Friday, 20 May 2022, 15:08 GMT
I think there are other packages that cover those scenarios. From the wiki page I linked:

> ## SandyBridge and newer (2011 onwards)
>
> As of linux 5.17 and TLP 1.5, no external kernel modules are required for advanced battery functions for ThinkPads from model year 2011 onwards (e.g. T420/X220 and newer), therefore installing acpi_call is not necessary anymore.
>
> If using linux-lts, install acpi_call-lts. If not running kernels from official repositories, install acpi_call-dkms.
>
> ## Before SandyBridge (until 2010)
>
> For ThinkPads before model year 2011, install tp_smapi or tp_smapi-lts, depending on which kernel version you are using.
Comment by Doug Newgard (Scimmia) - Friday, 20 May 2022, 15:15 GMT
And the dep covers those other packages.
Comment by mearon (mearon) - Friday, 20 May 2022, 16:47 GMT
Sorry, I don't know what you mean. Can you please elaborate further?

Loading...