Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74770 - [gnutls] kmymoney crash during save

Attached to Project: Arch Linux
Opened by Branimir Amidzic (ambra) - Monday, 16 May 2022, 14:06 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 25 May 2022, 18:24 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: KMyMoney 5.1.2-7 crashes every time I try to save modified file.


Additional info:
* 5.1.2-6 and 5.1.2-7

Steps to reproduce:
I have recently updated my system and since then KMyMoney crashes every time I try to save the modified file. I tried reverting to 5.1.2-6 but the same happens. I thing it's due to Plasma/KDE Framework updates from this weekend, because before that KMyMoney worked fine (version 5.1.2-6).

I think that rebuilding the package with new KF5 and Plasma dependencies would be sufficient.

This is my system:
Operating System: Arch Linux
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Kernel Version: 5.17.7-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
Memory: 14,6 GiB of RAM
Graphics Processor: AMD Radeon Vega 8 Graphics

Attached you may find the error produced (last few lines appear during the crash.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 25 May 2022, 18:24 GMT
Reason for closing:  Fixed
Comment by Antonio Rojas (arojas) - Monday, 16 May 2022, 14:44 GMT
Backtrace please
Comment by Branimir Amidzic (ambra) - Monday, 16 May 2022, 20:01 GMT
I attached the debug trace file according to instructions found at Arch Wiki site.
To me it doesn't tell much, but it might be useful to developers.
The last lines I get at gdb console when I try to save the file are:

Thread 0x7ffef5408640 (LWP 46412) exited]
malloc(): invalid size (unsorted)

Thread 1 "kmymoney" received signal SIGABRT, Aborted.
__pthread_kill_implementation (threadid=<optimized out>, signo=signo@entry=6, no_tid=no_tid@entry=0) at pthread_kill.c:44
44 return INTERNAL_SYSCALL_ERROR_P (ret) ? INTERNAL_SYSCALL_ERRNO (ret) : 0;

I tried to rebuild kmymoney package hoping that it would be fixed, but it didn't.
   trace.log (104.1 KiB)
Comment by Volker Tanger (vtanger) - Monday, 16 May 2022, 21:32 GMT
I can reproduce @ambra's error on current Garuda/Arch.
Additionally kMyMoney also crashes after running aqbanking to update bank accounts - also during a free()
Comment by Volker Tanger (vtanger) - Monday, 16 May 2022, 21:41 GMT
The different kMyMoney loglevels do not differ much for the essential part. There seems to be some dangling/invalid pointer being free'd...


::::::::::::::
loglevel normal
::::::::::::::
KMyMoneyPlugin::KMMStatementInterface::import start
free(): invalid next size (fast)


::::::::::::::
loglevel=INFO
::::::::::::::
KMyMoneyPlugin::KMMStatementInterface::import start
free(): invalid next size (fast)


::::::::::::::
loglevel=DEBUG
::::::::::::::
KMyMoneyPlugin::KMMStatementInterface::import start
free(): invalid pointer
Comment by Felix (zocker) - Tuesday, 17 May 2022, 14:54 GMT
Related Bug Report Upstream: https://bugs.kde.org/show_bug.cgi?id=453896

According to https://bugs.kde.org/show_bug.cgi?id=453896#c8 it's related to an update of
gnutls to version 3.7.5 and a downgrade to version 3.7.4-3 fixed it according to https://bugs.kde.org/show_bug.cgi?id=453896#c9 .

Comment by Felix (zocker) - Tuesday, 17 May 2022, 15:06 GMT
I can also confirm that after downgrading to gnutls-3.7.4-3 saving is possible. So that seems to be the issue.
Comment by Volker Tanger (vtanger) - Tuesday, 17 May 2022, 17:08 GMT
As I did not have a valid signature for the gnutls-3.7.4-3 in the cache my downgrade to 3.7.4-2 also prove to successfully solve the problem. Thanks for the workaround!

sudo pacman -U file:///var/cache/pacman/pkg/gnutls-3.7.4-2-x86_64.pkg.tar.zst
Comment by Antonio Rojas (arojas) - Friday, 20 May 2022, 10:40 GMT Comment by Andreas Radke (AndyRTR) - Wednesday, 25 May 2022, 14:55 GMT
Please test gnutls-3.7.5-2.
Comment by Felix (zocker) - Wednesday, 25 May 2022, 16:06 GMT
Works for me with gnutls-3.7.5-2

Loading...