Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74762 - llvm-libs 13.0.1-3 breaks foldingathome

Attached to Project: Arch Linux
Opened by merlock (merlock) - Monday, 16 May 2022, 00:07 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 19 June 2022, 09:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Upgrade to llvm-libs 13.0.1-3 breaks foldingathome (fah) GPU use.

Additional info:
* package version(s) llvm-libs 13.0.3-1
* config and/or log files etc.:

FAH log *after* upgrade: http://ix.io/3XSs (particularly starting with this line: 23:35:49:WU00:FS01:0x22:Failed to create OpenCL context:

FAH log after downgrading to llvm-libs 13.0.1-2: http://ix.io/3XSt

* link to upstream bug report, if any N/A

Steps to reproduce: Upgrade to llvm-libs 13.0.1-3; restart FAH. Error results.

Side note: Since FAH (and the amd-opencl) are AUR packages, I did rebuild both of them with llvm{-libs} 13.0.1-3 installed, with no change in this reported behavior.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 19 June 2022, 09:40 GMT
Reason for closing:  Not a bug
Comment by Evangelos Foutras (foutrelis) - Monday, 16 May 2022, 09:41 GMT
There was a slight ABI break in the new package due to being built with GCC 12; the two affected packages (blender and ispc) have been rebuilt.

Run the following on your system to possibly discover similarly affected binaries from installed AUR packages (download the attached txt file and run the command in a directory with it):

$ pacman -Qlq $(pacman -Qmq) | grep -v /$ | while read file; do grep -Fq libLLVM-13.so $file && readelf -Ws $file | grep -Fqf llvm-13.0.1-3-removed-symbols.txt && echo $file; done
Comment by merlock (merlock) - Tuesday, 17 May 2022, 03:01 GMT
Thanks for the hint/tip, @fourtelis.

I didn't find anything with my AUR packages.

I guess it has something to do with how FAH is compiled.
Comment by merlock (merlock) - Thursday, 19 May 2022, 02:26 GMT
So, it appears to be a problem in the *opencl-mesa* package. I had both opencl-amd (aur) and opencl-mesa concurrently installed. When I removed opencl-mesa, FAH started working properly again.

Loading...