Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74761 - [libguestfs] libyara.so.8: cannot open shared object file: No such file or directory

Attached to Project: Community Packages
Opened by samuel (arch_user) - Sunday, 15 May 2022, 19:36 GMT
Last edited by Toolybird (Toolybird) - Monday, 11 July 2022, 07:32 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Levente Polyak (anthraxx)
Robin Broda (coderobe)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: libguestfs-test-tool fails with the following error message:
guestfsd: error while loading shared libraries: libyara.so.8: cannot open shared object file: No such file or directory

It seems that libyara.so.8 was updated to libyara.so.9, but libguestfs still tries to access libyara.so.8

Additional info:
* package version: 1.48.1-2

Steps to reproduce: execute libguestfs-test-tool and find the error message
This task depends upon

Closed by  Toolybird (Toolybird)
Monday, 11 July 2022, 07:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  libguestfs 1.48.1-3
Comment by Doug Newgard (Scimmia) - Sunday, 15 May 2022, 20:03 GMT
There is no file called guestfsd in the repos. Whatever you have installed from elsewhere, it's your responsibility to rebuild it when needed.

Edit:OK, I may be wrong here, guestfsd may be inside an image in the package?
Comment by Antonio Rojas (arojas) - Sunday, 15 May 2022, 20:20 GMT
Yes, this is  FS#71327  again
Comment by David Runge (dvzrv) - Sunday, 15 May 2022, 21:09 GMT
@anthraxx can we add a note to the yara PKGBUILD so that depending packages are rebuild on soname change? This seems to be a reoccuring issue.
Comment by Levente Polyak (anthraxx) - Monday, 16 May 2022, 22:17 GMT
First time I actually even hear about any relation of libguestfs to yara, I've not even been assigned in  FS#71327  to get notified about it.

Quite unfortunate its hidden away in ./usr/lib/guestfs/supermin.d/daemon.tar.gz there is no way to let sogrep detect it.
I'll add a comment to the PKGBUILD, please someone rebuild libguestfs.
Comment by David Runge (dvzrv) - Sunday, 22 May 2022, 08:29 GMT
Cool, many thanks!
Comment by Adrien Wu (adrien1018) - Wednesday, 25 May 2022, 15:37 GMT
  • Field changed: Percent Complete (100% → 0%)
The package seems haven't been rebuild yet.

Loading...