Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74743 - [mumble] Requires libPocoZip.so.81

Attached to Project: Arch Linux
Opened by Éric (gileri) - Saturday, 14 May 2022, 19:06 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Saturday, 14 May 2022, 20:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Package mumble-1.4.230-5 is built against poco-1.11.1-1, and does not work with the current poco-1.11.2-1 with the following error :

mumble: error while loading shared libraries: libPocoZip.so.81: cannot open shared object file: No such file or directory

Additionally, there are two issues that kept me from compiling the current PKGBUILD :

https://github.com/mumble-voip/mumble/pull/5587 and then https://github.com/mumble-voip/mumble/pull/5616

Adding the two attached patches and amending the PKGBUILD allow it to build and run fine with poco-1.11.2-1.

Steps to reproduce:

1. Start mumble
2. Try to build mumble from ABS
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Saturday, 14 May 2022, 20:42 GMT
Reason for closing:  Fixed
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 14 May 2022, 19:59 GMT
Thanks a lot for the fix and sorry for the breakage. I didn't expect a patch version to break mumble.
Comment by Éric (gileri) - Saturday, 14 May 2022, 20:25 GMT
No worries at all, thank you for your work here !

Loading...