Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74718 - [mingw-w64-binutils] Building Wine fails with multiple makejobs

Attached to Project: Community Packages
Opened by Stelios Tsampas (loathingkernel) - Thursday, 12 May 2022, 10:53 GMT
Last edited by Chih-Hsuan Yen (yan12125) - Sunday, 05 June 2022, 15:15 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:

Compiling wine with multiple makejobs fails due to a dlltool issue.
The information and well as the patch are available below.
https://sourceware.org/bugzilla/show_bug.cgi?id=28885
This task depends upon

Closed by  Chih-Hsuan Yen (yan12125)
Sunday, 05 June 2022, 15:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  mingw-w64-binutils 2.38-3
Comment by Nu4425 (Nu4425) - Saturday, 14 May 2022, 21:59 GMT
Yes, I am also experiencing this bug when compiling wine (proton). This occurs when using the testing mingw-w64-gcc (12.1.0-1) rather than the stable version (11.2.0-1) along with the rest of the community mingw-w64-* toolchain. If it helps, a sample of the build error is attached.

Edit:
The bug also occurs in the latest stable release of mingw-w64-gcc (11.2.0-1). One workaround for this is to downgrade mingw-w64-binutils as suggested below:
https://github.com/Frogging-Family/wine-tkg-git/issues/764
Comment by Dmitry Skvortsov (Iglu47) - Wednesday, 18 May 2022, 17:41 GMT
the same here. please, somehow update package since it's already fixed in upstream.
(+1 vote to get attention)
Comment by Dmitry Skvortsov (Iglu47) - Wednesday, 18 May 2022, 19:29 GMT
rebuild with the patch - already allows me to build Wine.

@@ -11,9 +11,11 @@
depends=('zlib')
options=('!libtool' '!emptydirs')
validpgpkeys=('3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
-source=("https://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.gz"{,.sig})
+source=("https://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.gz"{,.sig}
+ "PR28885.patch")
sha512sums=('5160ff5c2a0ad41b880384216e21ada5328b51378e760c04269eb3b3626400d12abeeea72c14e18b52b969a0be94c8e5285c0b568bd5c82b7e69f68e0dfdc743'
- 'SKIP')
+ 'SKIP'
+ '175fbc02c15a1f3829bd970f10e5dd0b678fa3b7a95e6ae0b7e98f32992ac550d93038d3d94537425c89d8f0c2cfb5bc7d2ee0c6757db9f39618718576d124cc')

_targets="i686-w64-mingw32 x86_64-w64-mingw32"

@@ -21,6 +23,7 @@
cd "$srcdir"/binutils-${pkgver}
#do not install libiberty
sed -i 's/install_to_$(INSTALL_DEST) //' libiberty/Makefile.in
+ patch -Np1 < ../PR28885.patch
}

build() {

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=99852365513266afdd793289813e8e565186c9e6

upd. sorry, I have no idea how text formatting works here.
Comment by Chih-Hsuan Yen (yan12125) - Monday, 30 May 2022, 07:41 GMT
I can confirm PR28885.patch fixes parallel building for my custom wine build.

Felix: could you consider backport the aforementioned patch?
Comment by Chih-Hsuan Yen (yan12125) - Sunday, 05 June 2022, 15:06 GMT
Seems Felix fixed it but forgot to close the ticket :)

Loading...