Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74691 - FFMpeg is broken in the latest package

Attached to Project: Community Packages
Opened by binhex (binhex) - Tuesday, 10 May 2022, 09:23 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 10 May 2022, 10:20 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: FFMpeg is broken in the latest package (4.6.7.0-4), the softlink to /usr/bin/ffmpeg is circular and does not work:-

This is the output from the BROKEN version (4.6.7.0-4), note how ffmpeg softlink is circular and does not reference ffmpeg-arch:-
sh-5.1# ls -al ff*
-rwxr-xr-x 1 root root 247672 May 1 10:58 ffdetect-emby
lrwxrwxrwx 1 root root 20 May 6 17:18 ffmpeg -> /usr/bin/ffmpeg-emby
-rwxr-xr-x 1 root root 280688 Apr 30 14:50 ffmpeg-arch
lrwxrwxrwx 1 root root 15 May 1 10:58 ffmpeg-emby -> /usr/bin/ffmpeg
-rwxr-xr-x 1 root root 137320 Apr 30 14:50 ffplay
-rwxr-xr-x 1 root root 166576 Apr 30 14:50 ffprobe
lrwxrwxrwx 1 root root 16 May 1 10:58 ffprobe-emby -> /usr/bin/ffprobe
sh-5.1# ffmpeg
sh: ffmpeg: command not found

For reference, this is the same listing for the previous working version (4.6.7.0-3), note how ffmpeg is softlinked correctly to /usr/bin/ffmpeg-emby
sh-5.1# ls -al ff*
-rwxr-xr-x 1 root root 247672 Mar 6 16:09 ffdetect-emby
lrwxrwxrwx 1 root root 20 Mar 6 20:08 ffmpeg -> /usr/bin/ffmpeg-emby
-rwxr-xr-x 1 root root 280584 Mar 6 15:40 ffmpeg-arch
-rwxr-xr-x 1 root root 21702520 Mar 6 16:09 ffmpeg-emby
-rwxr-xr-x 1 root root 137224 Mar 6 15:40 ffplay
-rwxr-xr-x 1 root root 166480 Mar 6 15:40 ffprobe
-rwxr-xr-x 1 root root 21583896 Mar 6 16:09 ffprobe-emby

Additional info:
* package version(s) - 4.6.7.0-4
* config and/or log files etc. - See above
* link to upstream bug report, if any - N/A

Steps to reproduce:
Pull down latest package using pacman, start Emby and attempt playback of any media, you will receive the message `"No compatible streams are currently available. Please try again later or contact your system administrator for details.", if you look in the Emby log you will see the message "No video encoder found for 'h264'", which i believe it a symptom of a broken ffmpeg installation.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 10 May 2022, 10:20 GMT
Reason for closing:  Not a bug
Comment by Jonas Witschel (diabonas) - Tuesday, 10 May 2022, 09:40 GMT
/usr/bin/ffmpeg from the ffmpeg Arch Linux package should not be a symlink in the first place, but an actual binary. It seems as if you manually renamed ffmpeg to ffmpeg-arch and symlinked ffmpeg to ffmpeg-emby yourself, or possibly used an unsupported ffmpeg package that does this.
Comment by binhex (binhex) - Tuesday, 10 May 2022, 10:17 GMT
ahh sorry my mistake!, i had switched out the version of ffmpeg installed as part of this package as there is/was a known seek issue with later versions of ffmpeg, 4.0.2 being the version supported by Emby that works with seek. I will fix up the softlink issue, sorry for the incorrect bug report, i will request closure.

Loading...