Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74663 - [gdk-pixbuf2] 2.42.8-1 fails to load libavif.so.14 module

Attached to Project: Arch Linux
Opened by Marcell Meszaros (MarsSeed) - Friday, 06 May 2022, 15:38 GMT
Last edited by Antonio Rojas (arojas) - Friday, 06 May 2022, 16:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
[gdk-pixbuf2] optionally depends on [libavif].

After [libavif] update from 0.9.3-1 to 0.10.1-1 and
the latter's SO version bump from 13 to 14,
GDK-Pixbuf is unable to load libavif module

Maybe a rebuild would solve it?
([gdk-pixbuf2] was not bumped after [libavif] update.)

Additional info:
* package version(s):
-- [gdk-pixbuf2] 2.42.8-1
-- [libavif] 0.10.1-1

Steps to reproduce:
Upon update by pacman -Syu:
...
libavif 0.9.3-1 0.10.1-1
...
:: Running post-transaction hooks...
(3/5) Probing GDK-Pixbuf loader modules...
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-avif.so: /usr/lib/libavif.so.14: undefined symbol: I422ToARGBMatrixFilter
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 06 May 2022, 16:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  libyuv r2322+3aebf69d-1
Comment by Turbo B (Turbo) - Friday, 06 May 2022, 15:50 GMT
same thing.
Comment by Marcell Meszaros (MarsSeed) - Friday, 06 May 2022, 16:10 GMT
Turns out it's not a bug in [gdk-pixbuf2], but one in [libavif] 0.10.1-1:

See task  FS#74664 .

Loading...