Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74659 - [pipewire/pipewire-pulse] earbuds cannot connect after it connected other devices

Attached to Project: Arch Linux
Opened by sunghwan jung (sunghwan) - Friday, 06 May 2022, 11:28 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 19 June 2022, 09:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
My earbuds has paired with phone(android) and laptop(linux). After earbuds has connected and disconnected with phone, earbuds cannot connect to computer in some cases.

I reported this to bluez upstream (https://github.com/bluez/bluez/issues/336, you can see further information from this report), becuase I had thought this problem is related to bluez.
But It's not occured on ubuntu(22.04, bluez 5.64, pipewire 0.3.51 from debian-upstream ppa) and archlinux with pulseaudio-bluetooth.

this problem seems to be caused by pipewire packages.

Additional info:
Operating System: Arch Linux
KDE Plasma Version: 5.24.5
Bluez: 5.64-2
Pipewire and pipewire-pulse :0.3.51-1
Kernel Version: 5.17.5-arch1-1 (64-bit)
Bluetooth : Vendor ID 0x8087(Intel Corp.) Product ID 0x0a2a (Bluetooth wireless interface)
Earbuds : sony wf-xb700
* link to upstream bug report : https://github.com/bluez/bluez/issues/336

Steps to reproduce:
case 1: connect earbuds to phone -> disconnect from phone and turn off earbuds -> turn on laptop and wait a minutes after login -> turn on earbuds and try to connect -> fail to connect
case 2: connect earbuds to phone -> keep connection with phone and turn on laptop -> wait a minutes after login and disconnect from phone -> try to connect and fail to connect
In all fail case, it works again after turning off and on bluetooth adapter (not stop/start bluetooth service).
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 19 June 2022, 09:38 GMT
Reason for closing:  Works for me
Additional comments about closing:  Found a workaround with wireplumber, not pipewire.
Comment by sunghwan jung (sunghwan) - Friday, 06 May 2022, 22:31 GMT
I attached pipewire-bluez log.
Comment by sunghwan jung (sunghwan) - Wednesday, 11 May 2022, 17:44 GMT
I found a workaround.
disabling "bluez5.auto-connect" in /usr/share/wireplumber/bluetooth.lua.d/50-bluez-config.lua can fix it.
It may be caused by wireplumber, not pipewire.

Loading...