Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74631 - [gitlab] gitlab-backup failed

Attached to Project: Community Packages
Opened by Celogeek (celogeek) - Tuesday, 03 May 2022, 12:01 GMT
Last edited by Toolybird (Toolybird) - Friday, 08 July 2022, 03:14 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

When I run gitlab-backup through the service or manually I've got:

```
$ sudo -u gitlab $(cat environment | xargs) bundle-2.7 exec rake gitlab:backup:create
2022-04-29 19:07:07 +0200 -- Dumping database ...
Dumping PostgreSQL database gitlab ... [DONE]
2022-04-29 19:07:09 +0200 -- Dumping database ... done
2022-04-29 19:07:09 +0200 -- Dumping repositories ...
flag provided but not defined: -layout
Usage of create:
-locator string
determines how backup files are located. One of legacy, pointer. Note: The feature is not ready for production use. (default "legacy")
-parallel int
maximum number of parallel backups (default 8)
-parallel-storage -parallel
maximum number of parallel backups per storage. Note: actual parallelism when combined with -parallel depends on the order the repositories are received. (default 2)
-path string
repository backup path
rake aborted!
Backup::Error: gitaly-backup exit status 2
/usr/share/webapps/gitlab/lib/backup/gitaly_backup.rb:58:in `finish!'
/usr/share/webapps/gitlab/lib/backup/repositories.rb:21:in `ensure in dump'
/usr/share/webapps/gitlab/lib/backup/repositories.rb:21:in `dump'
/usr/share/webapps/gitlab/lib/backup/manager.rb:82:in `run_create_task'
/usr/share/webapps/gitlab/lib/backup/manager.rb:46:in `block in create'
/usr/share/webapps/gitlab/lib/backup/manager.rb:45:in `each'
/usr/share/webapps/gitlab/lib/backup/manager.rb:45:in `create'
/usr/share/webapps/gitlab/lib/tasks/gitlab/backup.rake:12:in `block (3 levels) in <top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sentry-ruby-core-5.1.1/lib/sentry/rake.rb:26:in `execute'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/exe/rake:27:in `<top (required)>'

Caused by:
Errno::EPIPE: Broken pipe
/usr/share/webapps/gitlab/lib/backup/gitaly_backup.rb:86:in `write'
/usr/share/webapps/gitlab/lib/backup/gitaly_backup.rb:86:in `puts'
/usr/share/webapps/gitlab/lib/backup/gitaly_backup.rb:86:in `schedule_backup_job'
/usr/share/webapps/gitlab/lib/backup/gitaly_backup.rb:66:in `enqueue'
/usr/share/webapps/gitlab/lib/backup/repositories.rb:56:in `enqueue_project'
/usr/share/webapps/gitlab/lib/backup/repositories.rb:47:in `block in enqueue_consecutive_projects'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:71:in `block (2 levels) in find_each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:71:in `each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:71:in `block in find_each'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:138:in `block in find_in_batches'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:245:in `block in in_batches'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:229:in `loop'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:229:in `in_batches'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:137:in `find_in_batches'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-6.1.4.7/lib/active_record/relation/batches.rb:70:in `find_each'
/usr/share/webapps/gitlab/lib/backup/repositories.rb:46:in `enqueue_consecutive_projects'
/usr/share/webapps/gitlab/lib/backup/repositories.rb:41:in `enqueue_consecutive'
/usr/share/webapps/gitlab/lib/backup/repositories.rb:18:in `dump'
/usr/share/webapps/gitlab/lib/backup/manager.rb:82:in `run_create_task'
/usr/share/webapps/gitlab/lib/backup/manager.rb:46:in `block in create'
/usr/share/webapps/gitlab/lib/backup/manager.rb:45:in `each'
/usr/share/webapps/gitlab/lib/backup/manager.rb:45:in `create'
/usr/share/webapps/gitlab/lib/tasks/gitlab/backup.rake:12:in `block (3 levels) in <top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/sentry-ruby-core-5.1.1/lib/sentry/rake.rb:26:in `execute'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/rake-13.0.6/exe/rake:27:in `<top (required)>'
Tasks: TOP => gitlab:backup:create
(See full trace by running task with --trace)

```

Additional info:
* package version(s)
14.10
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

- run backup

Solution (temporary):

Disable incremental backup feature:

On rails console
```
Feature.disable(:incremental_repository_backup)
```

I've report this here:

https://gitlab.com/gitlab-org/gitlab/-/issues/360961

It seems gitaly-backup on this build is outdated.
This task depends upon

Closed by  Toolybird (Toolybird)
Friday, 08 July 2022, 03:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  Appears resolved now that both gitlab and gitlab-gitaly were upgraded to version 15.1

Loading...