Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74612 - linux 5.17.5.arch1-1 fails to support areca raid controller ARC-12x4

Attached to Project: Arch Linux
Opened by Josh (T0pH4t) - Monday, 02 May 2022, 05:26 GMT
Task Type Bug Report
Category Kernel
Status Unconfirmed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Post install the linux kernel fails to boot the ARC-1224 raid controller (stalling kernel boot as it fails to mount drives), I'm going to assume that ARC-12x4 are all affected and possibly the ARC-12x6 series (most recent).
I've attached a dump of the controller failure in logs.It should be noted that this was an upgraded from kernel 5.15.10, so its possible this broke before 5.17. I have downgraded my kernel back to 5.15.10 (and 5.10.14) and
controller still works after attempting the upgrade to 5.17, so this should at least confirm its a kernel issue. As far as I know the modules for the areca cards are built into the kernels, there should be no third-party
installations required.

I may have to upstream this somewhere else... but I've used this companies cards for years and they generally just work...

Product Page, https://www.areca.com.tw/products/sasadapters-12x4.html
This task depends upon

Loading...