Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74497 - antlr4-runtime-4.10.1-1 files conflict with gtest

Attached to Project: Community Packages
Opened by Comminux (Lawrence_Kraft) - Monday, 18 April 2022, 17:55 GMT
Last edited by Konstantin Gizdov (kgizdov) - Tuesday, 19 April 2022, 06:04 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Package files conflict with gtest package.

Additional info:
* antlr4-runtime-4.10.1-1 from testing repo.
* pacman log:
:: Proceed with installation? [Y/n]
(7/7) checking keys in keyring [#####################################################################] 100%
(7/7) checking package integrity [#####################################################################] 100%
(7/7) loading package files [#####################################################################] 100%
(7/7) checking for file conflicts [#####################################################################] 100%
error: failed to commit transaction (conflicting files)
antlr4-runtime: /usr/include/gmock/gmock-actions.h exists in filesystem (owned by gtest)
antlr4-runtime: /usr/include/gmock/gmock-cardinalities.h exists in filesystem (owned by gtest)
antlr4-runtime: /usr/include/gmock/gmock-function-mocker.h exists in filesystem (owned by gtest)
...
Errors occurred, no packages were upgraded.

Steps to reproduce:
* Install antlr4-runtime 4.9.3-4 and gtest 1.11.0-3.
* Enable testing repo and then update your system.
This task depends upon

Closed by  Konstantin Gizdov (kgizdov)
Tuesday, 19 April 2022, 06:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  antlr4-runtime 4.10.1-2
Comment by loqs (loqs) - Monday, 18 April 2022, 20:16 GMT
Please try rebuilding antlr4-runtime with the attached diff applied that disables installation of the bundled gtest.
Comment by Comminux (Lawrence_Kraft) - Monday, 18 April 2022, 20:34 GMT
Compilation and installation goes correctly with this patch.
Comment by Kale Kundert (kalekundert) - Tuesday, 19 April 2022, 01:41 GMT
For what it's worth, it now seems like this conflict is in the community repository.

Loading...