Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74452 - [avidemux-qt] add wayland compability

Attached to Project: Arch Linux
Opened by Ruben Kelevra (RubenKelevra) - Tuesday, 12 April 2022, 12:54 GMT
Last edited by David Thurstenson (thurstylark) - Saturday, 16 July 2022, 11:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Currently avidemux-qt does not start under wayland (crashes instantly after start painting the windows).

This can be fixed by setting the parameter `--platform 'xcb'`.

Log:
```
[initGUI] 12:52:55-948 OpenGL enabled at build time, checking whether we should run it... no.
The screen seems to be 1920 x 1080 px
[destroy] 12:52:55-984 Destroying preview
[renderDisplayResize] 12:52:55-984 Render to 0x0 zoom=1,0000, old one =0 x 0, zoom=1,0000, renderer=(nil)
[UI_resize] 12:52:55-984 Resizing the main window to 233x210 px
[RDR] Resizing to 0 x 0
[initGUI] 12:52:55-994 OpenGL not activated, not initialized
Probing for VDPAU...
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 14 (X_GetGeometry)
Resource id in failed request: 0x4
Serial number of failed request: 40
Current serial number in output stream: 40
```

Steps to reproduce:
- Start avidemux-qt in a wayland session
- observe crash
This task depends upon

Closed by  David Thurstenson (thurstylark)
Saturday, 16 July 2022, 11:36 GMT
Reason for closing:  No response
Comment by Levente Polyak (anthraxx) - Tuesday, 12 April 2022, 16:14 GMT
I'm not sure what you try to point out here, if you try to raise an upstream behavior change you will need to report this upstream.

Loading...