Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7437 - Wireshark - Missing .desktop file

Attached to Project: Arch Linux
Opened by Calorì Alessandro (axelgenus) - Wednesday, 13 June 2007, 09:57 GMT
Last edited by Aaron Griffin (phrakture) - Friday, 09 May 2008, 17:23 GMT
Task Type Feature Request
Category Packages: Current
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity Very Low
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After installing Wireshark the only way to start it is from the terminal. No .desktop file is created in /usr/share/applications.

Additional info:
* package version : wireshark 0.99.5-3
* the filelist shows no .desktop file

Steps to reproduce:
1) Install wireshark
This task depends upon

Closed by  Aaron Griffin (phrakture)
Friday, 09 May 2008, 17:23 GMT
Reason for closing:  Upstream
Additional comments about closing:  Not an Archlinux bug/feature request
Comment by Thomas Bächler (brain0) - Thursday, 14 June 2007, 16:04 GMT
I can take care of it, but it would be faster if you could upload the .desktop file here.
Comment by Calorì Alessandro (axelgenus) - Thursday, 14 June 2007, 16:28 GMT
I found these .desktop file in the debian stable package. I Hope it helps...
Comment by Calorì Alessandro (axelgenus) - Thursday, 14 June 2007, 16:30 GMT
Ops, I forgot icons... ;)
Comment by Thomas Bächler (brain0) - Thursday, 14 June 2007, 22:26 GMT
Thank you. The -root file won't work though, as gksu is not installed on all systems, I will see if I can find another solution for that.
Comment by Calorì Alessandro (axelgenus) - Friday, 15 June 2007, 07:07 GMT
Suggestion: you can work it out as for the gnome-terminal.
Comment by Jan de Groot (JGC) - Friday, 15 June 2007, 07:16 GMT
Just add the .desktop file and prepend it with gksu, use gksu in the TryExec, so unless gksu is installed it will be hidden by default (IMHO gksu shouldn't be a dependency for wireshark)
Comment by Thomas Bächler (brain0) - Friday, 15 June 2007, 13:53 GMT
gksu has gnome dependencies, so it seems unfair to add it. I could use kdesu and gnome users would complain. Can we somehow test for alternatives installed and make it use either gksu or kdesu, whatever is installed in one .desktop file? If not, I will add two .desktop files, one for kdesu, one for gksu.
Comment by Calorì Alessandro (axelgenus) - Friday, 15 June 2007, 14:10 GMT
Don't add the -root one, just the other.
Comment by Roman Kyrylych (Romashka) - Friday, 15 June 2007, 14:12 GMT
2 .desktop files would result in 2 menu entries, no?
I suggest to make a wrapper script that tests for existence of gksu/kdesu and run the program through one of them (or just run without gksu/kdesu if none available).
And include one .desktop that calls that wrapper script.
Same solution could be implemented for other similar packages (*parted comes to mind).
Comment by Thomas Bächler (brain0) - Friday, 15 June 2007, 16:04 GMT
As Jan said, we could use TryExec and it would only show one entry if only gksu or kdesu is installed.
Comment by Jan de Groot (JGC) - Friday, 15 June 2007, 16:34 GMT
And it would show both when kdebase is installed on a gnome system with gksu. Playing around with the OnlyShowIn/NotShowIn option would fix that. Not shipping a root launcher would be easier though.
Comment by Corrado Primier (bardo) - Wednesday, 15 August 2007, 10:00 GMT
Is this task still active? My opinion is that a root launcher is not our first priority. IMHO, at the moment the real issue is there is no way to start wireshark using the menus.
Comment by Manuel C. (ekerazha) - Saturday, 25 August 2007, 13:22 GMT
On my system I have to run wireshark as root otherwise it doesn't detect the network interfaces, so maybe the "root launcher" should be a priority.
Comment by Corrado Primier (bardo) - Sunday, 02 September 2007, 10:25 GMT
Manuel, I'm not saying it's not a priority or that the root one shouldn't be included, I'm just saying that this could be done in two phases. Since writing the root file seems to be a problem, we could just start adding the user one while we look for a way to implement it.
Comment by Roman Kyrylych (Romashka) - Saturday, 09 February 2008, 17:08 GMT
status?
Comment by Manuel C. (ekerazha) - Saturday, 29 March 2008, 13:28 GMT
What about something like

xterm -e 'su -c wireshark'

?
Comment by Roman Kyrylych (Romashka) - Sunday, 06 April 2008, 07:36 GMT
xterm is not good.
for example, I don't have it installed ;)

I like this solution:

Comment by Thomas Bächler (brain0) - Friday, 15 June 2007, 18:04 GMT+2
As Jan said, we could use TryExec and it would only show one entry if only gksu or kdesu is installed.

Comment by Jan de Groot (JGC) - Friday, 15 June 2007, 18:34 GMT+2
And it would show both when kdebase is installed on a gnome system with gksu. Playing around with the OnlyShowIn/NotShowIn option would fix that. Not shipping a root launcher would be easier though.

However, this should be fixed by mainstream ( == someone should send .desktop to wireshark devs ) because we try to do things this way.
Comment by Manuel C. (ekerazha) - Sunday, 06 April 2008, 10:32 GMT
Well... and I don't have gksu and kdesu installed ;-D Maybe you could probe for "gksu" "kdesu" AND terminals like "xterm" "terminal" etc. However somebody could also install them AFTER having installed Wireshark.

Loading...