Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74347 - [kodi] Segfault on launch

Attached to Project: Community Packages
Opened by James Crompton (DonJaime) - Monday, 04 April 2022, 14:32 GMT
Last edited by David Thurstenson (thurstylark) - Wednesday, 27 April 2022, 22:32 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Kodi dies seconds after launch. Console output:

libva error: /usr/lib/dri/iHD_drv_video.so init failed
libva error: /usr/lib/dri/iHD_drv_video.so init failed
/usr/bin/kodi: line 186: 17913 Segmentation fault (core dumped) ${KODI_BINARY} $SAVED_ARGS
find: '/home/<me>/Photos/lost+found': Permission denied
Crash report available at /home/james/kodi_crashlog-20220404_162426.log
libva error: /usr/lib/dri/iHD_drv_video.so init failed
libva error: /usr/lib/dri/iHD_drv_video.so init failed
/usr/bin/kodi: line 186: 17913 Segmentation fault (core dumped) ${KODI_BINARY} $SAVED_ARGS
find: '/home/<me>/Photos/lost+found': Permission denied
Crash report available at /home/<me>/kodi_crashlog-20220404_162426.log

Crash report attached, though nothing much is in it.

Uninstalling the owner of /usr/lib/dri/iHD_drv_video.so doesn't help.
Deleting ~/.kodi and starting again doesn't help

* package version(s) 19.4-2

Steps to reproduce:
Start kodi from the app menu or from a terminal window.
kodi-standalone run from a virtual console does not do this. But doesn't respond to the keyboard or the mouse either, so isn't much use.
This task depends upon

Closed by  David Thurstenson (thurstylark)
Wednesday, 27 April 2022, 22:32 GMT
Reason for closing:  Fixed
Comment by Laurent Carlier (lordheavy) - Monday, 04 April 2022, 16:30 GMT
What is the video chipset ? If it's an old chipset, you can try mesa-amber package.
Comment by James Crompton (DonJaime) - Monday, 04 April 2022, 18:48 GMT
Iris Plus Graphics 640 (KabyLake GT3e). Same problem with TigerLake-LP GT2 [Iris Xe Graphics]. Nothing else has graphics problems.
Comment by Alb (pzdmrd) - Sunday, 10 April 2022, 16:15 GMT
The problem is (again) with latest python update(3.10.4-1)
Downgrading to python 3.10.2-1 fixes the problem

I also have "Intel Corporation Iris Plus Graphics 640" and downgrading python makes Kodi usable again

Comment by James Crompton (DonJaime) - Sunday, 10 April 2022, 17:01 GMT
System upgrade fixed it. Looks like something wasn't keeping up with something. File under quality control and close, I suppose.

Loading...